4

Right now it works with kernel 5.8 but in 5.11 (installed this morning along other upgrades) the wifi adapter doesn't get detected at all and apparently there are no fixes until the drivers gets patched (unless i'm mistaken). Do someone know if/when bcmwl-kernel-source will get patched?

edit: current version of bcmwl-kernel-source is 6.30.223.271+bdcom-0ubuntu7

PS: To be honest each time there's a kernel upgrade this adapter stops working... it's quite frustrating

3
  • Ubuntu LTS releases have two kernel options; the GA kernel is static for those wanting a stable system (it's the default for servers), or the HWE kernel choice (default for Ubuntu Desktop) for those wanting later drivers (ie. kernel modules) which get updated. If you want stability, why not switch to the GA kernel stack? FYI: You can even have both installed; so if you have issues with one, you've still got the other to boot with (selected at grub)
    – guiverc
    Aug 5 at 7:13
  • Thanks for the suggestion, i'll look into it :)
    – Emanuele
    Aug 5 at 7:34
  • 1
3

So i solved the issue by downloading a binary (deb) from here: https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu7~20.04.3

I uninstalled what i had, and installed bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu7_20.04.3_amd64.deb which was backported from Irsute Hippo which installs kernel 5.11 by default.

Before i had solved a similar issue from 5.4 to 5.8 by installing this binary bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu7_amd64.deb

Same version basically but fixed for 5.11. Probably that's why apt said i had the latest version installed (which was truish).

Hope this helps someone else.

1
  • 1
    Thanks! This solved the same symptom of my BCM4313. The …~20.04.3 version is (now?) in the focal repositories, so I only had to install that particular version with apt install bcmwl-kernel-source=6.30.223.271+bdcom-0ubuntu7~20.04.3. Now it works fine under 5.11.x kernels. [Still I don't get why it was not offered before as a security update, then apt declared i was downgrading the package version when force-installed, and now the previously installed version is not offered as a newer package…]
    – FairMiles
    Oct 2 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.