0

Good morning all.

The laptop is an HPP455 G2 with a 1TB SSD partitioned to include a separate Data partition. Secure boot is disabled. I have installed a dual boot Windows 10 and Ubuntu 21.04 system and (with some difficulty) had it working well.

Expected behaviour: On switch on or restart the system boots into the Ubuntu dual boot screen, allowing user to select Ubuntu or Windows; if no selection within ten seconds boots into Ubuntu.

Observed behaviour: On switch on or restart the system fails to boot with the error messages as below; looping through the initial post screen and into the error message. Selecting "Esc" at the post screen allows selection of efi boot options; the third of which is "ubuntu" - this takes me to the dual boot screen after which boot proceeds into the selected (or default) OS as expected.

On first installing the SDD I installed Windows then Ubuntu. Since the system did not boot properly I used 'Boot-Repair' Advanced options and followed the directions to "change the default boot entry of your Windows bootloader ... boot into Windows then type the following in an admin command prompt: bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi . The system then booted normally into the standard Ubuntu dual boot screen. It has been ok for the past three months or so.

Today I did a restart and I was unable to boot as normal, however could enter the EFI boot options screen and select Ubuntu, which then went to the dual boot screen from where boot is normal into Ubuntu or Windows.

I again used Boot-Repair Advanced options and again followed the directions to "change the default boot entry of your Windows bootloader ... boot into Windows then type the following in an admin command prompt: bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi . This did not sort the problem out.

Full details of error message:

  Failed to open \efi\ubuntu\S - Invalid Parameter

  Failed to load image \efi\ubuntu\S: - Invalid Parameter

  start_image() returned Invalid Parameter

The Boot repair log is at: https://paste.ubuntu.com/p/YcSFTnxjVZ/

I would be grateful for any advice.

2
0

I have the same issue. The only current solution is installing LTS 20.04.02. I found out that doesn't have this issue of corrupting the bootloader. Photo -> corrupted bootloader

I also made a thread on Overclock.net about this: https://www.overclock.net/threads/issues-with-21-04-corrupt-grub2-bootloader.1792799/

1
  • Thanks Bas, I'm going to report this as a bug. For now it is easy enough to use F9 on start up. Really helpful comments from you, thanks.
    – Springnuts
    Aug 5 at 16:57
-1

I personally installed windows and then ubuntu and turned on autoboot, secure boot is on and works fine. I did the same steps as yours and our systems are similar I think I would suggest you to enable secure boot and autoboot otherwise I have nothing else in mind sorry

4
  • Thanks Tuna. What machine were you installing to, please?
    – Springnuts
    Aug 4 at 11:05
  • ı have a laptop with AMD A8 R5 Graphics ı install it Aug 4 at 11:07
  • I think I will attempt some more diagnosis before trying this, thank you.
    – Springnuts
    Aug 4 at 11:09
  • If you don't have important files in Ubuntu, you can try to install version 19 or 20.04. The grub area I installed on Pardus was not working (pardus is a linux distribution looks like lubuntu), I reinstalled Pardus, sometimes such problems can occur, I can't comment further :( Aug 4 at 11:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.