0

Dear fellow ubuntu Users,

I have an Alienware laptop that has a dual boot with Windows 10 and Ubuntu 18.04. I use Ubuntu as my main operating system. I turned my pc off last night and when I try to turn it on this morning I faced a problem that takes me to Emergency mode.

When I turn pc on, Grub os selection menu appears. When I choose Ubuntu the booting screen takes way more time than usual and turns on in Emergency mode. (I can boot Windows 10 without any issues)

The screen says (Sorry for typos etc as I type it from my tablet looking at my pc screen):

[...] dell_symbios: Unable to run on non-Dell system
[...] dell_symbios: Unable to run on non-Dell system
[...] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
[...] ucsi-ccg 0-0008: i2c_transfer failed -110
[...] ucsi-ccg 0-0008: ucsi_ccg_init failed - -110

You are in emergency mode. After logging in, type ''journalctl -xb'' to view 
system logs, ''systemctl reboot'' to reboot, ''systemctl default'' or ''exit'' 
to boot into default mode.
press Enter for maintanence
(or press Control-D ti continue): 

Then it leaves me as the root in some sort of TTY mode.

"journalctl -xb" shows a log file with the lines on top as red. other booting options cause the same ubuntu screen with the beginning that takes a long time and fails.

The related lines of the "/etc/fstab" file are as follows:

# / was on /dev/nvme0n1p5 during installation
UUid=9666e669-5a8b-4a97-a954-f8477abafcfa / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/nvme0n1p2 during installatıon
UUID=DCD5-AE75 /boot/efi vfat umask=0077 0 1
/swapfile none swap sw 0 0

blkid command output is made of several lines of /dev/loopx:TYPE="squashfs" where x is a number between 0 and 29. Then another output is as follows:

/dev/nvme0n1:PTUUID=[some key in ""] PTTYPE="gpt"
/dev/nvme0n1p1:LABEL="Recover" UUID=[some key] TYPE="ntfs" partlabel="Basic data partition" PARTUUID=[some key]
/dev/nvme0n1p2: UUID="DCD5-AE75" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="05daf95a-bce2-411c-81ea-a647518768e7"
/dev/nvme0n1p3: PARTLABEL="Microsoft reserved partition PARTUUID=[some key]
/dev/nvme0n1p4: PARTLABEL="Basic data partition" PARTUUID=[some key]
/dev/nvme0n1p5:UUID="9666e669-5a8b-4a97-a954-f8477abafcfa` TYPE="ext4" PARTUUID="1627206a-8f4b-4650-83cb-9e4ca56f2660"

Additionally, I can boot Ubuntu 20.04 from a USB stick, however, it scans for something first. Unmounting and mounting nvme0n1p5 did not work out.

I really have no clue what to try out next. Hoping to have some suggestions.

Edit on 04.08.2021:

I tried to boot Ubuntu in recovery mode, it worked. I used the options available as dpkg, fsck, and grub, however that did not solve my issue.

Edit 2 on 04.08.2021:

I booted Ubuntu from a USB, installed boot-repair, and run the program. After removing the USB and booting again caused me to run into Grub minimal version.

I was able to get rid of Grub screen by following steps at question.

Edit 3 04.08.2021:

I tried what @heynnema has suggested here. But did not succeed, still stuck at the Grub.

Edit 4 04.08.2021:

After getting rid of it Ubuntu failed to boot with a few errors as follows:

Failed to start Load Kernel modules
...
Timed out waiting for device dev-disk-by\x2duuid-cdf4efdb...
Timed out waiting for device dev-disk-by\x2duuid-DCD5\x2dAE75.device

Then I commented out /etc/fstab by disabling line with /boot/efi but the result was the same.

One thing different is in /etc/fstab is that the line with /boot efi was changed as a new version with defaults rather than umask=0077. I guess this is not relevant, but am not sure.

Final Note: I formatted my Ubuntu OS.

7
  • It looks like Ubuntu is having trouble using the I^2C bus on your system, hence the errors. Could you ensure your ‘Fast boot’ mode setting in the system firmware is set to ‘Thorough’?
    – galexite
    Aug 3, 2021 at 15:13
  • Also, if you could run journalctl -xb at the Emergency Prompt (press Enter), and upload the results here, that would be useful.
    – galexite
    Aug 3, 2021 at 15:17
  • Hi @galexite, thank you for the comment. It might sound amateur but how do I set it to 'through'? Secondly about your second comment. It outputs more than a thousand line, I will try to get an output txt file for journalctl -xb
    – mert
    Aug 3, 2021 at 15:35
  • Hi, apologies, this should help: dell.com/community/Latitude/…
    – galexite
    Aug 3, 2021 at 16:56
  • You get two or three options, and you want either "Off" or "Thorough". This way, the system firmware initialises all devices thouroughly before booting the operating system.
    – galexite
    Aug 3, 2021 at 16:58

1 Answer 1

0

Ubuntu is unable to mount your EFI System Partition (ESP). You need to run fsck to identify what the problem is and repair it. From either the emergency console, or from a live CD (run sudo -i to get a root shell first if on the live CD), run the following commands:

# umount /dev/disk/by-uuid/DCD5-AE75     # if the disk is not mounted, don't worry
# fsck /dev/disk/by-uuid/DCD5-AE75

This UUID comes from the log files which you posted. Hopefully, fsck will detect any errors and correct them, but some boot files may have been corrupted. If the system does not boot after fsck is run still, you will need to run Boot-Repair.

10
  • If fsck gets stuck, we may need to format the EFI System Partition and restore the bootloader using Boot-Repair.
    – galexite
    Aug 4, 2021 at 8:23
  • Dear @galexite umount command failed saying it is already unmounted so it should be fine, fsck command seemed to be working, however after trying to boot it failed again. I will now try boot-repair.
    – mert
    Aug 4, 2021 at 8:32
  • @mert, could you comment out your /boot/efi line in /etc/fstab by placing a # character in front of the line? This will (temporarily) stop Ubuntu from trying to mount the ESP on boot.
    – galexite
    Aug 4, 2021 at 8:35
  • @Galaxite, atm I am following the leads boot-repair let me into. It seemed as it fixed some issues. But now booting gets me into a minimal bash, I am trying to figure out how to make ubuntu boot loader is defined in the firmware. grub minimal bash takes me to windows when I type exit. Long story short after finishing the paths I got here, Iwill try your last suggestion as well.
    – mert
    Aug 4, 2021 at 9:10
  • @mert, GRUB has lost its configuration. You must run the default Boot-Repair suggestion again, because you need to restore its configuration, or we need to chroot to the system partition and reinstall grub/run update-grub.
    – galexite
    Aug 4, 2021 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.