I've installed Ubuntu 21.04. I've followed a few AskUbuntu guides to no avail. My monitor is connected with an HDMI via an AMD RX 580 (Ellesmere) video card.

I do not have any proprietary drivers installed. As it so happens, official amdgpu-install drivers or amdgpu-pro drivers aren't supported in 21.04. In Ubuntu Software as well I see no drivers for my video card.

lspci Displays two audio devices:

  • Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
  • Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller

In Settings > Sound > Output Device, there's only S/PDIF - Family 17h.

I've tried pulseaudio -k and rebooting.

I've installed Pulse Audio Volume Control (pavucontrol). Pulse Audio > Configuration > Ellesmere HDMI Audio > Profile displays a list of 18 digital stereo and digital surround HDMI outputs. ALL of these profits have (unplugged) (unavailable) in the end, and none of them are able to bring out any audio.

Below is my alsamixer screenshot which I don't understand - is something muted here? I cannot change the values of the "00" either by + or by the up arrow.

alsamixer screenshot

  • @mathieu-pagé This is related: askubuntu.com/a/1301214
    – Raffa
    Oct 18, 2021 at 9:10
  • 1
    Are you very sure there are no shorts in your hdmi cable or any bad plugs male or female? Have you tested your speakers/monitor so there are no shorts? Has your computer been tested and you are sure there are no intertnal shorts? Sometimes these problems can be a simple thing like that. Oct 20, 2021 at 22:17

2 Answers 2


Try wiggling the HDMI cable at the connectors. That's what the problem has been with mine several times over the years. A poor connection. And I have several HDMI cables going to several pieces of equipment. I've learned to check that connection first.

If it's strained in any way, perhaps get a 90 degree connector cable or adapter.

  • Um, the video is working fine. It's a single monitor setup, it's not an external either. Video is working which means the connection is fine, been using the same setup on Windows for years for both video and audio, both still work on Windows (dual booted).
    – Abhimanyu
    Aug 2, 2021 at 10:39

You should probably be seeing a different device available for sound output, something like "HDMI ...", as here. I don't think you should expect handling configuration for an S/PDIF device, in alsamixer or else.

The device is supported, Device 'AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]' and it seems to have worked in 21.04, at least in some cases, I don't know how you concluded it doesn't, or which driver you were referring to.

enter image description here enter image description here enter image description here

Even the HDMI audio alone seems to work, even if with some things to double check.

enter image description here enter image description here enter image description here

I assume you are certain your monitor has audio capabilities. I suggest you post the brand/model of your monitor, plus the output of the commands below. Also, try connecting the PC to a standard TV via HDMI and post what you see.

$ uname -a
$ lspci -nnk | grep -n -A 4 -i 'Audio'
$ inxi -F
$ hwinfo --monitor
$ aplay -l
$ sudo lshw -C multimedia
$ dpkg -l | grep alsa
$ cat /etc/pulse/default.pa
$ pactl list | grep -ni hdmi
$ pactl list modules short
$ dpkg -l | grep pulseaudio-module
$ pacmd list-cards
$ pacmd list-sinks
$ pacmd list-sink-inputs

You might need to install applications you don't have, e.g.

$ sudo apt install inxi hwinfo pacmd

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .