0

i am sorry to ask such question, but being new to coding, i can't solve this problem even with googling full 2 days. so here it goes.

I'm trying to run a demo posted at github using ubuntu for window10. there, i made a env using python 2.7.13 by virtualenv. i need to use tensorflow 1.3.0 with python 2.7 to run this demo, but when i try to install tensorflow==1.3.0 by pip (pip install tensorflow==1.3.0), it prints out No matching distribution found. same for tensorflow, tensorflow-1.3.0, tensorflow1, tensorflow==1, tensorflow==1.3 etc. i tried to build it myself or use the source file for tensorflow==1.3.0 in git but i got stuck everytime because i kept getting into different problems such as unable to install python-pip, linux(something)-wrapper, etc.

please, is there a way to install tensorflow==1.3.0 in virtual environment using python 2.7.13 or is there anything i can try?

oh! and while i still have no idea on what happen to python2 on janury 1st 2020, my main(?local? i don't know... the one that was installed in ubuntu) python version is 3.8. python2.7 is just for the virtual environment.

pip version is 20.3.4

honestly, i don't even know which part is wrong..

i tried looking at the /etc/apt as the internet said that is the source file, and there were some lines starting with

deb http://archive.ubuntu.com/ubuntu/

but i guess they only matter when installing things by apt-get install..?

so maybe it's a pip problem and i should downgrade it as the project on github was lastly edited on july 2020...?

2
  • 1
    If you must have TensorFlow 1.3 from about four years ago, the simplest option would be to use a Docker image as it comes mostly configured for you 👍🏻
    – matigo
    Jul 31 at 7:27
  • ohh! i will try! thank you!
    – Hyeon
    Jul 31 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.