3

At the moment, this is how the date and clock looks like in Ubuntu's top bar:

Date and clock in Ubuntu's top bar

In Estonian, "R" stands for "Reede" or "Friday", and "Juuli" means "July".

How can I make the date show day/month/year in numbers instead of letters and words?

4
  • 1
    I prefer date +"%Y-%m-%d" and you can replace - by / or anything else, and change the order, so I think this command; date +"%d/%m/%Y" may be what you want. See info date for more details.
    – sudodus
    Jul 30 at 16:49
  • 1
    @Frappy Since you mentioned "Ubuntu's top bar". You most probably using default DE that is GNOME. You can install gnome shell extension for what you are looking for. extensions.gnome.org/extension/1206/clock-override
    – UnKNOWn
    Jul 30 at 16:59
  • 1
    Sorry. I read 'date' in the title to mean the command line date. But UnKNOWn was reading your question more correctly.
    – sudodus
    Jul 30 at 17:22
  • 1
    @UnKNOWn Thank you! That's what I was looking for.
    – Frappy
    Jul 30 at 18:36
4

Your question is similar to this one (not sure if it should be considered a duplicate), so I'm copying my answer from there, modifying the clock format to the one you want.


There are several extensions in the GNOME Shell Extensions website, but most of them are not actively supported anymore. I'm suggesting you to use the Panel Date Format extension, which works fine on Ubuntu 20.04 and is still maintained.

To customize your clock after installing the extension, follow these steps:

  1. Open Extensions, find the Panel Date Format extension in the list and click the gear icon next to it.

  2. You will be presented with this Preferences menu (image from the extension's GitHub repository):

    preferences menu

  3. In the Format textbox enter the following to get the time format you want:

    %d/%m/%Y %H:%M
    

    You can find more info about the date time format syntax here (link also mentioned in the extension's preferences).

  4. Restart GNOME Shell to ensure that the setting is applied by pressing Alt+F2, entering r and pressing Enter.

Your panel's clock should now have the appearance you want!

0

Thanks, but I tried this already before posting my question. I installed the clock-override and panel-date-format gnome extensions manually, but they didn't show up in extensions (although other extensions I installed in the same way did). I have a fresh install of 20.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.