-1

I have never installed a Linux distribution before, and want to install Ubuntu 20.04 if possible alongside my fresh install of Windows 7 (update problems) on my HP ENVY 6 notebook.

Ubuntu install started and all works until "Installation type - window" first says:

Your installation medium is on /dev/sdc1. You will not be able to create, delete or resize partitions on this disk, but you may be able to install to existing partitions there.

Then I see a partition table: /dev/sdc ... (my USB drive only), and "device for bootloader installation": /dev/sda.

When I leave and start GParted within Ubuntu Live, an error message pops up saying

invalid argument during seek for read on /dev/sdc (retry/cancel/ignore)

but after that shows me all partitions on the computer.

gparted:

- /dev/sda1 ntfs system (flags boot)
- /dev/sda2 ntfs os 
- unallocated
- /dev/sda3 fat32 hp_tools (flags lba)
- unallocated 3.34MiB

- /dev/sdb1 4 GiB (flags irst)
- unallocated 26 GiB

I also tried with boot manager

  • from EFI file option1: USB (ACPI...), option2: hp_tools (ACPI...)
  • USB drive with UEFI
  • USB drive

Also Ubuntu 16.04 can't see my SSD partitions when installing alongside Windows 10 did not resolve the problem.

Output Ubuntu Live terminal:

$ sudo parted /dev/sda unit s print
Model: ATA Hitachi HTS54323 (scsi)
Disk /dev/sda: 625142448s
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Disk Flags: 

Number  Start       End         Size        Type     File system  Flags
 1      2048s       409599s     407552s     primary  ntfs         boot
 2      409600s     215326719s  214917120s  primary  ntfs
 3      624928768s  625135615s  206848s     primary  fat32        lba

Windows 7:

  • Windows BIOS mode is legacy
  • Hibernation (disabled)
  • MBR partition type

Disk 0 (basic):

  • System (ntfs)
  • OS C: (ntfs)
  • Unallocated (~200GB)
  • HP Tools (fat32)

Disk 1 (basic):

  • ... healthy (hibernation partition)

BIOS settings:

  • BIOS InsydeH20 Rev.3.7 F.16, 10 17 2021
  • Hardware VT (disabled)
  • Intel rapid start technology (disabled)
  • Legacy support (enabled)
  • Secure boot (grayed out/can't alter, but says disabled)
  • Boot order is: USB, then Hard Drive, then the rest

Options in BIOS are limited.

1
  • Whey was this question voted down? Just trying to understand. Jul 28 at 15:12
0

It looks like your SSD is using msdos partition table, which means you need to boot the live USB in BIOS/Legacy mode and install it that way. If you want to use UEFI, you may need to use GPT partition table. There are tools that might allow you to convert msdos to GPT such as this one https://superuser.com/questions/1250895/converting-between-gpt-and-mbr-hard-drive-without-losing-data However, create a backup first as you may lose your data.

3
  • I think I already tried BIOS mode before, when I start with boot manager and choose the usb option that doesn't mention UEFI, a different boot screen appears, but unfortunately this didn't solve the issue. Correct me if I misunderstand, anyway thanks for the comment.
    – nicketik
    Jul 29 at 14:31
  • I think you are correct. To install the via BIOS mode, you do select the USB option that does not mention UEFI. The only other things I can think of is: 1. Try rewriting the ISO to the USB using a tool like Etcher 2. Ensure secure boot and fast boot options in BIOS settings is off Jul 29 at 14:36
  • First i used rufus, now balenaEtcher, works fine as well, I also tried with different usb drives, and ubuntu versions, but it made no difference. However, I stumbled upon a clue. I'll report about it, after I reconsidered what the problem might be.
    – nicketik
    Jul 29 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.