The top, "File, Edit..." menu is gone from all my KDE program windows. Not sure what I changed.

I tried ctrl+m, looked in EVERY setting I can find for days but can not find a way to get my File menu back.

Best I can do is add a an item to the Title Bar buttons for, "Application Menu" which is ok but not what I want.

Menus gone

  • It's a widget not a default option in KDE
    – Am.Shekari
    Aug 8, 2021 at 9:53

3 Answers 3


I've faced the same problem for quite a long time, trying all possible intuitive tricks and tips, but there's no change even after updating to Ubuntu 22.04 (KDE Plasma 5.24.7).

Today by chance I found the toggle! Now menu bars are back where a common user would expect them. I don't need to press Alt+F anymore to scroll out File options from top left corner of the main screen and move by keyboard arrows in the menu.

How to: Go to Settings -> Startup and Shutdown -> Background Services -> Startup Services -> turn off Application menus daemon.

  • I feared it would deactivate the "Window AppMenu" widget inside The Panel bar. No, after disabling it, it really only shows the menu bar inside the window of non-KDE-applications. For some reason, it still hides the menu bar in KDE applications such as Dolphin or Settings (either coded or another config). So I still need the "Window AppMenu" widget for KDE-applications. In other cases it shows the menu bar twice. It can be turned into a "hamburger button" (in the configurations of the widget choose "use single button for application menu") or only show for maximized apps. Yet another trade-off Feb 17 at 2:05

You can add Globel-menu widget and from there you have a menubar, resembling Gnome style.

To add it: Add widgets -> Globel menu

You can configure it too

  • This description is incomplete. You need to right-Click on "The Panel" (i.e. the "status bar" where your applications or the application launcher icon is shown). Then you can find the "Add Widgets…" context menu entry. Feb 17 at 1:44

You have to remove (drag it out) the three-line button from the screen you are showing. Then ctrl(+shift)+m will work

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .