1

I'm getting the infinite log in loop on Ubuntu for just one of my user accounts - I've tried all of the recommended solutions (modifying .Xauthority, /temp/ and using lightdm)

Strangely when I ctrl+shift+f3 and login to the problem account - my working directory is "/" rather than "/home/username/"

Incase it is relevant, my the permissions for the problem account are dr-------- 31 usrnm usrnm ...

Does anybody know how I can fix or troubleshoot?

Thanks for any help!

5
  • That should be at least rwx for your user.
    – muru
    Jul 26 at 9:40
  • 1
    You got it in one thanks very much! I ran sudo chmod a+rwx /home/usrnm/ and can now log in! Jul 26 at 9:57
  • 2
    Does this answer your question? Can't log in my ubuntu laptop, login loop
    – muru
    Jul 26 at 10:06
  • Hi, I had tried this solution and failed because "~" was directing to "~" - now that I understand the problem it was on the right lines Jul 26 at 10:17
  • 1
    @Charlie griffin, please, don't put SOLVED in the title, but write an answer with the solution you found. Jul 26 at 10:22
2

(Solution with thanks to muru)

The problem was with the permissions for /home/usrnm/. I fixed it by logging into the problem account by Ctrl+Shift+F3 and then running sudo chmod a+rwx /home/usrnm/

1
  • More usual permissions would be u=rwx,go=rx or octal 755 (you don't really want *all to be able to write to your home dir) Jul 26 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.