0

When launching System monitor it goes to fullscreen. How to set it to smaller screen size on start?

This has now been resolved thanks

0

When I set System Monitor full screen, then close it, next time it relaunches, it will start full screen.

In other words: normal behavior is that it remembers the size of the window at the time it was closed.

In particular, the application sets the dconf setting org.gnome.gnome-system-monitor maximized on true whenever you maximize the window. It stores the current window size of the not maximized window in org.gnome.gnome-system-monitor window-state.

Thus, unmaximize the window, then close the application to have it start with regular window size next time.

Additional caveat: Depending on the settings of the window manager, a large window may be automatically maximized by the window manager. That could explain why you have the impression that it always starts maximized. So make sure you make the window sufficiently small for it not to be maximized automatically. Whether a window that is near the size of the monitor is automatically maximized or not is determined by the dconf setting org.gnome.mutter auto-maximize. You can disable that behavior by setting this to false.

gsettings set org.gnome.mutter auto-maximize false
4
  • Sorry, forgot to mention I am using Mate. System-monitor was in slightly different location but when I found it, as you say it was set to maximise. Changed it and now Monitor window opens as expected. But if I maximise the window before closing, it will re-open at fullscreen again. I have to change it again in dconf but would prefer if it was a permanent change but can live with this. I did also disable org.gnome.mutter. Thank you for your help Jul 24 at 14:33
  • It just remembers the window size as you last set it. That's all. One could script and change its settings before launching to always launch in a preset way.
    – vanadium
    Jul 24 at 14:35
  • Thanks I'll live with it as it's getting beyond my skills level and I've left the "I'll be careful" warning when opening dconf editor as a reminder! Thanks again for your help Jul 24 at 14:38
  • For sure. I tpersonally hink the best behavior of a program is to just remember the window size as you last set it.
    – vanadium
    Jul 25 at 9:53
0

Brute force method is to reset all system monitor settings:

  • for MATE System Monitor use

    gsettings reset-recursively org.mate.system-monitor
    
  • for GNOME System Monitor use

    gsettings reset-recursively org.gnome.gnome-system-monitor
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.