Installed 12.04 on HP laptop with wireless hardware switch. Apparently no driver included in 12.04, and can't find one via driver update. Worked fine with 10.04 and Win XP. Seems to me that Broadcom b43 is what worked with 10.04 but I'm not absolutely sure about that. Ideas?

  • 1
    We need hardware info. Run lspci. If its broadcom chip, see here -> askubuntu.com/questions/125529/…. Else post the output of lspci – Web-E May 11 '12 at 6:51
  • Is the reference to 'hardware switch' relevant? Is Wireless disabled (at BIOS level) ? – david6 May 11 '12 at 7:25

It happened the same to me after an upgrade, on 12.04.

Simply resolved with rfkill unblock all

(rfkill list all showed some devices on soft block)


Try shutting down(if not already off), disconnecting the AC power, remove battery, press power a few times to release stored energy, reinsert battery, reconnect AC power. Turn on Laptop. Worked for me. After trying multiple fixes I found on the internet I remembered reading this somewhere. My hardware was blocked via a hardware switch(fn+f8) which doesn't work in ubuntu(works with windows, but uninstalled windows). rfkill showed 0: phy0: Wireless Lan as Hard Blocked.

  • And look for a hardware WiFi on/off switch; I am used to there being a push-button above the keyboard, but the Dell laptop we recently acquired has a sliding switch on the side! – Lawrence Dol Sep 26 '13 at 20:06

Have you worked way through this? This has worked for me in the past https://help.ubuntu.com/12.04/ubuntu-help/net-wireless-troubleshooting.html


Broadcom wireless cards are a little complicated with linux. Like nVidia and Radeon, Broadcom provides linux drivers, but they are not open source. Ubuntu has Jockey (or Additional Drivers Tool) to help with this. Apparently, Jockey has a hard time identifying certain broadcom chipsets [1] and loads the wrong driver. This is also covered in the Ubuntu Documentation.

I have had the best luck installing the b43-fwcutter and firmware-b43-installer packages, but this may be different for your hardware.

[1] - Ubuntu Forums Topic #11923344 post #2. The whole topic may be helpful to you as well.


Are you absolutely sure it is the wireless driver which is not working? I found that one router was set to channel 13 and some wireless card drivers won't work above Channel 11. Something to do with US Channels vs rest of the world.

If possible check the wireless router is at a channel between 1 to 11 and re-boot. (This is unlikely to be the cause if you ARE in the United States).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.