0

There is no screenshot on the clipboard when calling my screenshot-shortcut xfce4-screenshooter -rc or xfce4-screenshooter -mcw. I first asked a question on https://gitlab.xfce.org/apps/xfce4-screenshooter/-/issues/60 but finally I was directed here because it was not the right forum.

I am using xfce4-screenshooter 1.9.7 under Xubuntu 18.04.5 LTS currently with kernel 5.4.0-80-generic x86_64.

I have created various keyboard shortcuts, namely:

  • xfce4-screenshooter -rc to capture a rectangular region of my screen to the clipboard,
  • xfce4-screenshooter -mcw to capture the actual window with mouse pointer to the clipboard,
  • xfce4-screenshooter -fmd 7 -o gimp-2.8 for a delayed screenshot to be sent to gimp in order to select the region of interest there.

Sometimes the first and the second one of them don't work. The first one shows me the cursor cross and lets me select a region (which proves that xfce4-screenshooter is involved), but after selecting the region no screenshot can be pasted from the clipboard. The target application (in many cases LO Writer or Gimp) waits for a long time before it tells me that there is nothing on the clipboard, or in the case of LO Writer, it just pastes some text which happened to be on the clipboard before my screenshot. In case of Gimp, it tells me, that no image data are on the clipboard.

I have not installed any special clipboard manager like ClipIt or the like. In fact I was unaware about the existence of such programs. But since I was asked in the other forum whether I use a clipboard manager: I did not install any of them actively and I don't even know the name of the program which actually manages the clipboard. It is definitely neither ClipIt nor xclipboard. If it is part of X: The version of my X is "X.Org X Server 1.20.8".

In the other forum I was recommended to try with xfce4-screenshooter version 1.9.9 or 1.9.8.

Unfortunately I was unable to find the right package to install a more recent version of xfce4-screenshoter on my Xubuntu 18.04.5 LTS. Instead I ruined my system running into dependence problems. Fortunately I could easily reinstall a recent image to overcome this bigger problem.

From where can I find a package for xfce4-screenshooter version 1.9.9 or 1.9.8. to be installed on my system?

2
0

You can manually download and install xfce4-screenshooter 1.98 from the default Ubuntu 21.10 repositories in Ubuntu 21.04. Open the terminal and type:

sudo apt update  
wget http://mirrors.kernel.org/ubuntu/pool/universe/x/xfce4-screenshooter/xfce4-screenshooter_1.9.8-1_amd64.deb
sudo apt install ./xfce4-screenshooter/xfce4-screenshooter_1.9.8-1_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.