0

I was doing some machine learning with Nvidia GPU when I ran into an error that was CUDA related. I decided to reboot my computer to fix the error but when booting Ubuntu, my screen freezes. I opened up the GRUB console to see what was happening and it was freezing at

Starting GRUB failed boot detection
Starting Authorization Manager

I tried to reboot again, it was recovering journal and clearing orphaned inodes until this popped up

/dev/sda8: clean, 2757878/46759936 files 155438410/187020544  blocks

And then froze there, only being able to manually reboot my computer.

I then tried launching in recovery mode :Linux 5.8.0-63-generic In the grub loader, this starts ubuntu, assigns my user, mounts, and flushes my journal to persistent storage, it outputs started Load/Save RF Kill Switch Status and then it freezes. Doing it a second time caused it to get past that and output Finished Flush Journal to Persistent Storage. at which point nothing happens and I can't do anything.

I have also tried following this article : https://itsfoss.com/fix-ubuntu-freezing/

I edited the params with nomodeset and this ended up freezing at

[   OK   ] Started Hostname Service. 
systemd-hostnamed.service

Trying nouveau.noaccel=1 ends up freezing on

[   OK   ] Started Authorization Manager.
systemd-user-sessions.service
polkit.service
          Starting Modem Manager...
          Starting Hold until boot process finishes up...
          Starting Hostname Service...

Finally replacing quiet splash with noapic noacpi nosplash irqpoll causes a black screen where nothing comes up after waiting 10 minutes.

An important note is that I had an update that I hadn't applied yet.

Other things I have tried:

1.) Booting into rescue target (systemd.unit=rescue.target)

Result: Freezes at ```failed to start show plymouth boot screen```

2.) Booting into emergency target(systemd.unit=emergency.target)

Result: Message displays saying I am in emergency mode and asks for root password for 
maintenance or press Control-D To continue. Blinking typing sign shows up for a second and 
then dissapears. I cannot type or press Control-D and seems to be frozen.

I then finally tried booting with init=/bin/sh and I have access to an shell finally but I am at a loss at what I should start doing.

The top of my shell states /bin/sh: 0: can't access tty: job control turned off

I remounted my drive, and ran systemctl enable debug-shell.service which created a sym link and is supposed to give me access to a root shell from an early point so I can check systemctl logs. I also tried running fsck -f / and fsck -f /dev/sda8 to check my disk but it said

/dev/sda8 is mounted
e2fsck: cannot continue, aborting.

I reboot and boot in using the normal ubuntu and after pressing ctrl + alt + f9, a root shell comes up with my user but I only have a few seconds before it freezes entirely again

What is causing this issue and any suggestions on fixing it?

1 Answer 1

0

I went in and booted with init=/bin/sh again and ran these commands to uninstall Nvidia Drivers

sudo apt-get remove --purge '^nvidia-.*'
sudo apt-get install ubuntu-desktop
sudo rm /etc/X11/xorg.conf # This command did not work as file doesn't exst
echo 'nouveau' | sudo tee -a /etc/modules

I rebooted normally and it got to the Ubuntu log in screen, with screen zoomed in but that is something that will require installation of nvidia drivers again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.