First of all, I really want to apologize for any rare questions about Linux and Ubuntu. The thing is I'm practically new to GNU/Linux and the Linux kernel itself. I know pretty much the basis of it. But let's head into the problem.

I've recently updgraded from linux-kernel-5.8.0-55 to linux-kernel-5.8.0-63 because Ubuntu itself showed me that I could upgrade it (using the upgrade GUI, not the CLI).

Everything went fine until I booted into the new kernel version and figured out that I didn't had network connection anymore.

Mi past with this problem and what I've done to solve it:

The same happened before and I just installed kernel 5.8.0-55 using a USB cable connected to my cellphone. I downloaded it from my android device and moved it into my PC.

The question I made here was written with the intention to:

1- Solve this issue.

2- Have a better understanding of what is happening with my PC, how Linux works under the hood and understand what have I done wrong.


I figured out that somehow my network device's drivers are not even being recognised by the distro. How can I solve this? Why is happening every time?

Also, my NVIDIA drivers disappeared too.

What I've tried:

sudo apt-get install --reinstall linux-image-extra-`uname -r`

Thinking that would reinstall my previous installation. What happened after:

Could not find any package with the regular expression «linux-image-extra-5.8.0-55-generic»

I also searched the web, switched to my other kernel 5.8.0-59 and have the same problem there.

VERSION Linux 5.8.0-55-generic #62~20.04.1-Ubuntu

  • 1
    Welcome on Linux! It is very unlikely that the kernel upgrade is itself the reason for the breakage. Working devices tend to keep working after minor kernel upgrades. How did you install your network drivers and NVidia drivers? Via the "Software & Updates" GUI, "Additional Drivers"? In that case what may happening is that the kernel modules / (proprietary) drivers somehow do not get compiled or installed properly when you upgrade the kernel. You could try reverting, then reapplying the additional drivers.
    – zwets
    Commented Jul 22, 2021 at 23:55
  • @zwets Hey! Thanks for your time. Amm, the drivers were automatically installed, I mean, when I installed ubuntu for the first time they were just there (the network ones too). I tried to revert the installation but it didn't work :/. Also, I installed everything from the pop-up window that alerts you that software can be upgraded. More specifically, from: "Software upgrades".
    – idunno
    Commented Jul 23, 2021 at 0:15
  • 1
    Having same issue here. I too believe it is the kernel update. What motherboard you using? Does it have a 2.5g lan port?
    – Guest
    Commented Jul 23, 2021 at 3:35
  • 1
    Does it work correctly if you choose the old kernel during boot?
    – WU-TANG
    Commented Jul 23, 2021 at 4:15
  • @WU-TANG Hello! Yes, indeed! But the problem now is that Ubuntu deleted nvidia drivers and my resolution is the worst. I have network connection in 5.8.0-55.
    – idunno
    Commented Jul 23, 2021 at 11:27

1 Answer 1


I fixed it! But I still don't understand what happens when upgrading my kernel :P.

What I did was:

1- Uninstalled NVIDIA drivers (to fix nvidia drivers problem) using:

sudo apt-get remove --purge nvidia-* -y

2- Executed sudo ubuntu-drivers autoinstall.

3- Rebooted

And everything got solved! I now have internet connection (because of driver rtl8188eu wich comes as default on ubuntu 20.04).

But I have another problem now: I don't understand what caused the error, how to prevent it and what is happening under the hood.

Any comment would help or anything pointing towards wikis and stuff.

I really really appreciate the time everyone took to answer to my questions.

  • 1
    you probably want to install dkms and see if that helps the next time around
    – WU-TANG
    Commented Jul 24, 2021 at 7:06
  • @WU-TANG I did a research about it and found an epic answer in this same forum. I'll leave it here in case someone needs to understand as me! askubuntu.com/questions/408605/… Now, I'll head onto learning again. Thanks for your time.
    – idunno
    Commented Jul 24, 2021 at 15:41
  • 1
    That's informative, but I'm thinking all you may need is sudo apt-get install dkms ... and then wait and see what happens next kernel update.
    – WU-TANG
    Commented Jul 25, 2021 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .