0

I performed a clean install of Ubuntu 20.04 and there are certain directories I want to restore from my Deja Dup backup (only one complete backup performed). I chose to use duplicity, as I want to specify these directories only.

To see the correct paths for the directories I need, I did:

list-current-files <URL>

I tried to restore chosen directories to a new directory in my home directory using:

duplicity -t 3D --no-encryption --file-to-restore <path of backup directory> <URL>  </restore_path/>

I receive the following error:

Error '('Error creating directory </restore_path>', 7)' processing 

I did:

duplicity collection-status <path to backup>

and received the following:

Last full backup date: <date>
Collection Status
-----------------
Connecting with backend: BackendWrapper
Archive dir: /home/karen/.cache/duplicity/9394baecea6181912d51fe8d3bff0034

Found 0 secondary backup chains.

Found primary backup chain with matching signature chain:
-------------------------
Chain start time: <date>
Chain end time: <date>
Number of contained backup sets: 1
Total number of contained volumes: 16661
 Type of backup set:                            Time:      Num volumes:
                Full         <date>             16661
-------------------------
No orphaned or incomplete backup sets found.

Please can you help with the "Error creating directory" message that I receive, as I don't know what it means.

Thanks in advance.

1 Answer 1

0

How are you inputting your restore directory?

I believe I had the same error and solved it by placing a /dir at the end like so:

/media/USER/TARGET_DRIVE/dir

I found that answer in an old thread somewhere. Been too focused on restoring my own backup to make the bookmark, sorry.

A complete restore command should look like this:

sudo duplicity restore file:///media/USER/BACKUP_DEVICE/BACKUP_SOURCE /media/USER/TARGET_DEVICE/dir

As a disclaimer it's not working for me, but I'm quite certain the issue isn't with the above command but with a file in my backup.

Also: you may, or may not have to use sudo.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .