2
  • OS: Ubuntu studio 21.04.
  • GPU: GeForce GTX 980

It's an operating system that has pre-installed software like the animation software called blender. I downloaded the operating system here: https://ubuntustudio.org/

But when I try running blender, it tells me I can't use the graphics card because of a Cuda software issue so it will use the CPU instead. My graphics card is a GeForce GTX 980 and I know that it's compatible with Cuda by running the command

lspci | grep -i nvidia

After I ran that command, I get: 2d:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 980] (rev a1) So I'm assuming that means it should work because it has the word compatible in the sentence.

When I go to the cuda website it says that the latest supported ubuntu version is Ubuntu 20.04.2 LTS, not the 21.04 version I have.

The tutorial I found online didn't work for me.

I also tried this But the terminal says The following packages have unmet dependencies: libcuinj64-11.2 Recommends: libnvcuvid1 but it is not installable

Does anyone have a working method of installing Cuda on Ubuntu studio 21.04?

0

1 Answer 1

1

I solved my issue by learning from this tutorial.

The commands I used were:

  • sudo ubuntu-drivers autoinstall
  • sudo apt install nvidia-driver-460
  • sudo reboot

  • sudo apt-get update
  • sudo apt-get install nvidia-cuda-toolkit

Now my graphics card works with blender.

I think the issue was: that the nvidia driver version that was auto installed was the wrong one. I remember seeing the phrase "unmet dependencies" and nvidia 460 the first round I tried installing cuda but didnt think nothing of it. But in the new install method, I looked up possible nvidia driver installations with the command ubuntu-drivers devices that listed a reccomended nvidia 470 driver. At first I tried doing that with the command sudo apt install nvidia-driver-470 then trying to re-install cuda with the sudo apt-get install nvidia-cuda-toolkit command but it didnt work. Only When I installed the older version of nivida with the sudo apt install nvidia-driver-460 command did it work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.