0

So its been a long time dream of mine to run Fireworks on Linux I assume somehow I am running the wrong version? gamemode is already the newest version (1.5.1-0ubuntu3.1).

Running with

  • Lutris: 0.5.8.3
  • Kernel: 5.8.0-53-generic
  • Wine version: lutris-6.10-7-86_64
  • DKVK version: v1.7.3L-03f11ba

Error Log

Running gamemoderun /home/hutber/.local/share/lutris/runners/wine/lutris-6.10-7-x86_64/bin/wine /mnt/users/Games/Games/fireworks/drive_c/Program Files (x86)/Adobe Fireworks CS6/Fireworks.exe
Initial process has started with pid 251133
Start monitoring process.
gamemodeauto: 
ERROR: ld.so: object '/usr/$LIB/libgamemodeauto.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgamemodeauto.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgamemodeauto.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgamemodeauto.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
wineserver: using server-side synchronization.
ERROR: ld.so: object '/usr/$LIB/libgamemodeauto.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: ld.so: object '/usr/$LIB/libgamemodeauto.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
Monitored process exited.
Initial process has exited (return code: 13568)
All monitored processes have exited.
Exit with returncode 13568
3
  • 1
    Is your $LIB set to lib/x86_64-linux-gnu ?
    – ubfan1
    Jul 17 at 0:28
  • Ahh smart and also obvious!! $LIB is not set to anything! Jul 17 at 1:12
  • Ok so the $LIB is set now to the correct path. echo $LIB lib/x86_64-linux-gnu But I am confused I assume I point to my system usr/lib folder and not the VM's as that does not exsit. Jul 17 at 1:19
0

Yeah so you're missing the 32bit libs. Remove gamemode (apt remove gamemode --autoremove), and download the Debian packages:

https://packages.debian.org/sid/amd64/gamemode/download
https://packages.debian.org/sid/amd64/gamemode-daemon/download
https://packages.debian.org/sid/amd64/libgamemode0/download
https://packages.debian.org/sid/amd64/libgamemodeauto0/download
https://packages.debian.org/sid/i386/libgamemode0/download
https://packages.debian.org/sid/i386/libgamemodeauto0/download

then install all .deb's with this command:

apt install -f path/to/gamemode.deb path/to/gamemode-daemon.deb ... This should fix your problem.

Taken from: https://github.com/FeralInteractive/gamemode/issues/254#issuecomment-643648779

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.