I have a Ubuntu 21.04 fresh install but my Wifi is not working. It states: "Wi-Fi adapter not found". The card is an Intel wifi 6 AX200. When writing lshw -C network it shoes network unclaimed And it says nothing about wifi 6 ax 200, it says something about realtek. Ubuntu 21.04 should be compatible since its kernel is >5.1 as required by this wifi card. Any help will be greatly appreciated... D

Edit after chili555's comment: lspci -nnk | grep 0280 -A3

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. Device [10ec:8852]
    DeviceName: Realtek Wireless LAN + BT
    Subsystem: Hewlett-Packard Company Device [103c:88e1]
04:00.0 Non-Volatile memory controller [0108]: Sandisk Corp WD Black SN750 / PC SN730 NVMe SSD [15b7:5006]

In the laptop specs it says it should have an Intel Wifi6 AX200!

  • Please edit your question to show the result of the terminal command: sudo modprobe iwlwifi && sudo dmesg | grep iwl Welcome to Ask Ubuntu.
    – chili555
    Jul 16, 2021 at 15:55
  • Hi! Nothing appears, just asks for my password and nothing else... Jul 16, 2021 at 18:12
  • How can I check if I have the necessary firmware? I've cd into lib/firmware/ and then ls but all the iwlwifi files seem to have different names to the one I need (iwlwifi-cc-46.3cfab8da.0.tgz as per Intel webpage)? Jul 16, 2021 at 18:26
  • 1
    I am wondering if you do not actually have an Intel. Please edit your question to show the result of: lspci -nnk | grep 0280 -A3 I love a mystery!
    – chili555
    Jul 16, 2021 at 18:53

3 Answers 3


Of course, if you wish, you could return the laptop and request that you instead receive a replacement equipped with the captioned Intel AX200. As well, you could easily install the correct driver for your Realtek device.

With a temporary internet connection by ethernet, tethered or whatever means possible, open a terminal and do:

sudo apt update
sudo apt install -y git build-essential
git clone https://github.com/lwfinger/rtw89.git
cd rtw89
sudo make install
sudo mkdir /usr/lib/firmware/rtw89
sudo cp  rtw8852a_fw.bin  /usr/lib/firmware/rtw89/
sudo modprobe rtw89pci

Your wireless should now be working.

EDIT: From time to time, when security flaws are corrected, when bugs are fixed or when new features are added, Update Manager will offer updates that include ‘Complete Linux Image’, that is, a newer kernel version than that installed today. After the update is installed, you will be prompted to restart to complete the update. After you restart, your wireless will no longer be working. To restore the wireless, open a terminal and do:

cd ~/rtw89
git pull
sudo make install
sudo modprobe rtw89pci

Please retain the rtw89 file and these instructions for that time.

At some future time, the rtw89 suite of drivers will be included in the latest kernels and this process will no longer be required. We haven’t yet any idea when that may occur.

  • Thank you very much! I'm going to contact them and see what solution they provide. Thank you so much for your time! <3 Jul 16, 2021 at 20:34
  • Hi! I come with an update: I just followed your instructions to install the Realtek driver and voilâ, I have Wi-Fi! I don't really understand how to update when kernel changes? Could you explain that a bit more? I don't understand what you mean by retaining the rtw89 file. Should I do the cd~/rtw89 etc commands before updating? I'm sorry, I'm quite new to this... Jul 19, 2021 at 12:19
  • 1
    No worries; all of us were new users at one time, even me! Please see my edit in a few moments. Also, if my answer has been helpful, please accept it: askubuntu.com/tour The searchers will appreciate it.
    – chili555
    Jul 19, 2021 at 13:22
  • Also, I recommend that you edit your question to change the title to something like: WiFi adapter not found Realtek 10ec:8852 again, to help the searchers. A great value of the site is to not only to help you but also to help many others with the same issue who find the answer that helped you.
    – chili555
    Jul 19, 2021 at 13:40
  • @chili555 If you have the time, can you see if you can help with askubuntu.com/questions/1352653/…? Thanks.
    – heynnema
    Jul 20, 2021 at 2:47

When running "sudo modprobe rtw89pci" above, you may run into 'operation not permitted' problems.

sudo modprobe rtw89pci   - 'operation not permitted'

This is because of SecureBoot enabled in your OS. You can follow this link to check and disable SecureBoot.

sudo apt-get install mokutil
mokutil --sb-state
sudo mokutil --disable-validation

Then you need to reboot and follow instructions to disable mok secureboot.

After reboot, run "sudo modprobe rtw89pci" again. It should work.

Good luck!

  • FYI. The wifi disappeared again overnight. I tried below and the wifi just came back. cd ~/rtw89; sudo make install; sudo modprobe rtw89pci; Note that don't try to run 'make' as you don't have internet access. Since I have finished 'Make' last time, I just did 'make install'
    – Lin
    Dec 1, 2021 at 18:00
  • I always run those commands when connected to ethernet so for me it's not a problem! Dec 2, 2021 at 21:23

When ubuntu gets updated, wifi driver may stop working. When you try install the driver again you may get the following error:

modprobe: ERROR: could not insert 'rtw89pci': Exec format error

This happens because you are trying to install the previously compiled files on the new kernel. The solution is to compile the files again. One possible way to do this is to

cd rtw99
rm *.o # removes previous .o files
sudo make install
sudo mkdir /usr/lib/firmware/rtw89
sudo cp  rtw8852a_fw.bin  /usr/lib/firmware/rtw89/
sudo modprobe rtw89pci
  • Thank you for your answer, I didn't even update ubuntu...For some reason today it worked on its own, just had to repeat @chili555 commands from the previous accepted answer Nov 9, 2021 at 13:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .