0

I have found a lot of questions here with the same issue as mine, but so far none have solved it. enter image description here

My wifi adapter is not recognized, my wifi screen simply says "No Wifi adapter found" In some other answers I've been told to run this command and post the results

dylan@dylan-HP-Desktop-M01-F1xxx:~$ lspci -nnk | grep 0280 -A3
09:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
    Subsystem: Hewlett-Packard Company RTL8821CE 802.11ac PCIe Wireless Network Adapter [103c:831a]
    Kernel modules: rtl8821ce
0a:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)

I also ran some other commands I found in this answer Link, but still I am having the same issue.
I'm sorry if this has already been solved, i genuinely couldn't figure it out myself. Results from comment:

sudo dmesg | grep 8821
[    8.614458] Bluetooth: hci0: RTL: examining hci_ver=08 hci_rev=000c lmp_ver=08 lmp_subver=8821
[    8.617444] Bluetooth: hci0: RTL: loading rtl_bt/rtl8821c_fw.bin
[    8.617763] Bluetooth: hci0: RTL: loading rtl_bt/rtl8821c_config.bin

7
  • Please edit your question to show the result of the terminal commands: sudo modprobe rtl8821ce and also: sudo dmesg | grep 8821 cfg80211??
    – chili555
    Jul 15 '21 at 16:02
  • the first one tells me operation not permitted Jul 15 '21 at 17:27
  • 1
    Please try disabling Secure Boot in the BIOS/EFI and try again.
    – chili555
    Jul 15 '21 at 19:12
  • I have also tried this. I do not have secure boot enabled Jul 15 '21 at 20:17
  • How about: sudo modprobe -vv rtl8821ce What are the accompanying messages?
    – chili555
    Jul 15 '21 at 21:34
2

In our chat, in an attempt to find the reason that the driver would not start as expected, we examined the make.log created by the dkms install. It is riddled with warnings: https://paste.ubuntu.com/p/smwRJsWQtW/

I suggested that, instead, we install this driver: https://github.com/lwfinger/rtw88.git When we examined the result of ‘make’, we saw that it proceeded perfectly, with no errors or warnings at all. I recommended that you keep this driver and remove the previous dkms install.

This driver must be reinstalled every time that Update Manager offers a newer kernel version. After the requested reboot, with a temporary internet connection by ethernet, tethering or whatever means possible, do:

cd rtw88
make clean
git pull
make
sudo make install
sudo modprobe rtw_8821ce

Your wireless should be working again. Please retain the rtw88 file and these instructions for that time.

Finally, after disabling Secure Boot, your wireless is working as expected.

0

I had some problems with wifi driver (I have the same driver as yours) on Xubuntu 21.04. I had to change system to Ubuntu 20.04. Here wifi works much better, but after sleep it sometimes do not see the adaptor. I type in terminal

sudo modprobe -r rtl8821ce && sleep 10 && sudo modprobe rtl8821ce

Then sleep, then type it again. An empty wifi-triangle appears. It is empty, but connection works! To check if there still is "no adapter found" try to go to Settings > Wifi.

1
  • I am using ubuntu 20.04, I ran your command and it gave me modprobe: ERROR: could not insert 'rtl8821ce': Operation not permitted Jul 15 '21 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.