I need to be able to connect to computer running Lubuntu 20.04 with Chrome remote desktop. I have installed it with dpkg -i. After adding a couple of required dependencies it has set up smoothly. Then I launched it only to get this screen: enter image description here Should I click the blue button it initiates downloading and installing... exactly the same deb-file (this time with GUI tools: Qapt or Discover). Round and round in circles I go...

I found this advice: How can I "Turn On" Chrome remote desktop in Ubuntu 20.04?. No dice for me. Did not change a thing.

Also, I tried to uninstall it with dpkg --purge. and install again. It is still the same.


What I found out so far.

I found an informative answer on how to start investigating the issue in the thread Can't Configure Chrome Remote Desktop (it is not the accepted answer, but the second one).

I executed service chrome-remote-desktop status and realised the CRD service was masked, i. e. not running. Executing sudo systemctl unmask chrome-remote-desktop.service changed nothing. So, I followed the second answer (again, not the accepted one) of https://unix.stackexchange.com/questions/308904/systemd-how-to-unmask-a-service-whose-unit-file-is-empty.

It helped me to actually start the service. Now it is up and running.

Unfortunately, it has been just a part of the problem, CRD still fails to run. And finally, I have stumbled at the step usermod -a -G chrome-remote-desktop "$USER" of the mentioned thread Can't Configure Chrome Remote Desktop for it returns usermod: group 'chrome-remote-desktop' does not exist and I do not understand whether it is important (but it looks like logging does not work without this step).

  • 1
    dpkg doesn't automatically resolve dependencies. Use apt or apt-get to install and uninstall software
    – Nmath
    Jul 14, 2021 at 20:53
  • 1
    @Nmath Well, normally, I do use apt, but there is no way to install Chrome RD with it. It comes in form of deb-files. And your statement it is not quite true. When I run dpkg -i for the first time it refused to work precisely because of dependency issues. That smart behaviour got me surprised pleasantly. I had to install the missing stuff first (with apt). That being said, generally, you are right.
    – S. N.
    Jul 14, 2021 at 21:18
  • 2
    Actually, you can use apt to install a .deb file with sudo apt install ./package.deb. The -i flag in dpkg will check for dependencies and fail if the conditions are not met. In both cases, downloading and installing a .deb file from the internet is about the worst way to install software in Ubuntu/Linux. If you need Chrome, a better method is to install from the PPA.
    – Nmath
    Jul 14, 2021 at 22:24
  • 1
    Even better, install Chromium from the snap store with sudo snap install chromium. Both browers are developed by Google. Chromium is actually the open source browser that Chrome is derived from. The main difference between Chromium and Chrome is that Chromium is open source and does not contain all of the proprietary hidden/secret code that Google adds to the Chrome browser that is used to track you, datamine you, advertise to you, and who knows what else...
    – Nmath
    Jul 14, 2021 at 22:25

1 Answer 1


For me, Chrome Remote Desktop recently updated and I was unable to start a xsession due to errors. I patched it to make it connect to the existing physical screen, which worked previously (before the update), but it doesn't work now due to (what appears to be) xauthority issues. I'm running a server, so I can't open x to all local users, so I tried for an hour to find a fix to no avail. Then, I gave up on ChromeRDP because it appears there is no solution to the problem (at least none I could devise). Anyway, I had countless issues with ChromeRDP prior to it breaking completely, including random disconnects, broken x sessions, freezing up the x session, black unusable desktop, randomly stopping working, the computer suddenly disappearing from the list of connectable computers, etc. So, the solution is to just port forward. If you can't port forward (e.x. it's a laptop), then (as far as I can tell) you're SOL. To date, I have yet to find any other suitable no-port-forwarding alternative RDP software.

I wish I could be more help and I realize that this is not much of an answer, but I hope that explaining my struggles and how ChromeRDP finally broke completely (every successive update to date has made ChromeRDP more and more buggy on Linux) might help. Unfortunately, you missed the easiest RDP software that ever existed by about 6 years. Back in 2015, ChromeRDP was as simple as one-click install on Linux and it never gave me a single issue.

  • 1
    Well, thank you for your extensive answer. It is a shame that handy and robust piece of software degraded so much only to become an error-prone one. That being said, I appreciate you sharing your impressions. I suppose, I shall have to think of another solution.
    – S. N.
    Jul 19, 2021 at 5:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .