I'm trying to install transmission on Ubuntu Server 12.04. But I'm running into few issues, The main one now is that the setup seems to hang on:

DHT Attempting bootstrap from dht.transmissionbt.com (tr-dht.c:247)

Here is the guide I have followed: link.

Installing the transmission daemon went fine, But when I tried to configuring it, It gave me the above issue.

The command is: transmission-daemon -f -t -u your_username -v your_password -w /path/to/downloaded/torrents -g /etc/transmission-daemon/

At first I used '&' symbol in the password and that messed some things up. I restarted the server and then used the same command with a password without '&' it goes through. The command does hang for a while on the line

transmission-daemon requiring authentication (daemon.c:508)

but then after say 20 seconds or so, It goes on to the line

DHT Attempting bootstrap from dht.transmissionbt.com (tr-dht.c:247)

It hangs there for over 10 min. The next line should be something about starting port forwarding.

When I look for the files that the command should have created, They look fine, Username is set, Not sure where to find the password though.

Still I cannot continue, And if I quit the command with Ctrl+C, when I run the remote GUI, It doesn't connect (it doesn't say more than that).

Any idea what is wrong? Any idea on how to go about figuring this out?

Sidenote: when running transmission-daemon -f -t -u your_username -v your_password -w /path/to/downloaded/torrents -g /etc/transmission-daemon/ for the first time, it said it failed to allocate the correct size to something UDP, and said to edit a file to specify the larger size. I did so, rebooted, and that issue was gone once re-trying.

Not sure if this helps but this is what comes after executing the command:

[22:31:21.566] Transmission 2.51 (13280) started (session.c:718)

[22:31:21.567] RPC Server Adding address to whitelist: * (rpc-server.c:803)

[22:31:21.567] RPC Server Serving RPC and Web requests on port (rpc-server.c:997)

[22:31:21.568] RPC Server Whitelist enabled (rpc-server.c:1001)

[22:31:21.568] RPC Server Password required (rpc-server.c:1004)

[22:31:21.568] Port Forwarding Stopped (port-forwarding.c:181)

[22:31:21.569] DHT Generating new id (tr-dht.c:309)

[22:31:21.569] Using settings from "/etc/transmission-daemon/" (daemon.c:488)

[22:31:21.569] Saved "/etc/transmission-daemon/settings.json" (bencode.c:1731)

[22:31:21.570] transmission-daemon requiring authentication (daemon.c:508)

[22:32:13.576] DHT Attempting bootstrap from dht.transmissionbt.com (tr-dht.c:247)


[22:57:39.319] Saved "/etc/transmission-daemon/settings.json" (bencode.c:1731)

[22:57:39.320] DHT Saving 67 (67 + 0) nodes (tr-dht.c:366)

[22:57:39.320] Saved "/etc/transmission-daemon//dht.dat" (bencode.c:1731)

[22:57:39.321] Port Forwarding Stopped (port-forwarding.c:181)

Closing transmission session... done.
  • also, when doing sudo service transmission-daemon restart the command errors our with Couldn't read "/var/lib/transmission-daemon/info/settings.json": Permission denied – Andy May 11 '12 at 12:55

Just had this one myself and it is fixed easily by changing ownership of the file:

sudo chown debian-transmission:debian-transmission /var/lib/transmission-daemon/info/settings.json

This got me back and running right now. You can also try changing the user and group to root:debian-transmission if the previous doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.