4

I have redshift installed on a XUbuntu 21.04. Apparently it's a service systemd[4048]: redshift.service: Failed with result 'exit-code' and it runs at startup.

I'd like to disable redshift on startup, but I can't find where and in which format it's started:

> systemctl stop redshift
> Failed to stop redshift.service: Unit redshift.service not loaded.

systemctl list-units --type=service Doesn't list it

The only thing that worked so far was a couple of sudo killall redshift calls right after booting

2 Answers 2

2

According to RedShift filelists it has systemd service for users.
To disable it use command below:

systemctl --user mask redshift.service redshift-gtk.service

and then reboot.

Also it is known that redshift service is broken at least on Ubuntu MATE 21.04, so really we can prevent its start on LightDM startup by executing the following commands for manual masking:

sudo mkdir -p /var/lib/lightdm/.config/systemd/user
sudo ln -sf /dev/null /var/lib/lightdm/.config/systemd/user/redshift.service  
sudo ln -sf /dev/null /var/lib/lightdm/.config/systemd/user/redshift-gtk.service
sudo chown -R lightdm: /var/lib/lightdm/.config

Note: Xubuntu also uses LightDM, so the above will work for it too.

4
  • Didn't work for me. Service kept starting.
    – DarkTrick
    Jul 11, 2021 at 23:42
  • Use mask instead of disable.
    – N0rbert
    Jul 12, 2021 at 1:20
  • Removing is no option, as I'm actually using it - just not as service.
    – DarkTrick
    Jul 12, 2021 at 1:30
  • This worked for me using redshift 1.12 on Pop OS 21.04 Jan 28 at 10:59
1

@N0rbert's solution did not work for me, although it was a pointer in the right direction.

I found user services in /usr/lib/systemd/user and changed redshift.service to redshift.service.disabled. That stopped running on boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.