25

Is there anyway to reduce the mouse sensitivity in Ubuntu 12.04?

I've used the slider on the systems settings to set it to the lowest point but it's still too fast.

  • 2
    You should be able to change Option "Sensitivity" for your pointing device in xorg.conf or a configuration file in /usr/share/X11/xorg.conf.d (or create one). See this forum topic and this Xorg.conf documentation. It should be possible for someone to put together the information in this comment, to produce an actual answer to this question (but I feel this is not by itself good enough to be an answer). – Eliah Kagan May 10 '12 at 18:59
  • @EliahKagan For me, fiddling with this forced me into console on reboot. The answer below worked fine though. – Sparhawk Apr 24 '13 at 23:34
31
  1. looking for mouse device id or name
  2. $ xinput --list
    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ A4Tech USB Full Speed                     id=10   [slave  pointer  (2)]
    ⎜   ↳ A4Tech USB Full Speed                     id=11   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Power Button                              id=7    [slave  keyboard (3)]
        ↳ CHESEN USB Keyboard                       id=8    [slave  keyboard (3)]
        ↳ CHESEN USB Keyboard                       id=9    [slave  keyboard (3)]
    
  3. setting mouse sensivity
  4. $ xinput --set-prop 10 "Device Accel Constant Deceleration" 4
    don't know why there are two same names so have choosen id by random. and it worked out.
  5. telling system to do this after logging in
  6. create script:
    #!/bin/bash
    xinput --set-prop 10 "Device Accel Constant Deceleration" 4
    xinput --set-prop 10 "Device Accel Velocity Scaling" 1
    
    then run command:
    $ gnome-session-properties
    and add the script to the list.
    don't forget about chmod +x.

information was found here and here.

11

An other option is xset.

The command format is

 xset mouse <acceleration> <threshold>

To reduce mouse acceleration

 xset mouse 1 1

To increase the mouse speed

 xset mouse 10 1

mouse may be abbreviated to m. The parameters for the mouse are acceleration and threshold. The acceleration can be specified as an integer, or as a simple fraction. The mouse, or whatever pointer the machine is connected to, will go acceleration times as fast when it travels more than threshold pixels in a short time. This way, the mouse can be used for precise alignment when it is moved slowly, yet it can be set to travel across the screen in a flick of the wrist when desired. One or both parameters for the m option can be omitted, but if only one is given, it will be interpreted as the acceleration. If no parameters or the flag 'default' is used, the system defaults will be set. If the threshold parameter is provided and 0, the acceleration parameter will be used in the exponent of a more natural and continuous formula, giving precise control for slow motion but big reach for fast motion, and a progressive transition for motions in between. Recommended acceleration value in this case is 3/2 to 2, but not limited to that range.

acceleration defines how many times faster the cursor will move than the default speed. threshold is the velocity required for acceleration to become effective, usually measured in device units per 10ms. acceleration can be a fraction, so if you want to slow down the mouse you can use 1/2, 1/3, 1/4, ... if you want to make it faster you can use 2/1, 3/1, 4/1, ...

For more info check out https://wiki.archlinux.org/index.php/Mouse_acceleration

0

In case s. o. has trouble with the mouse being too fast, check out this solution that implies that the graphical setting is uninitialized:

https://ubuntu-mate.community/t/mouse-too-fast-in-18-04-again-known-methods-stopped-working/18805

-3

in terminal type

vi mouse.sh

then paste your config in

xinput --set-prop 12 "Device Accel Constant Deceleration" 5

quit and save

then do

chmod +x mouse.sh 

then in gnome-session-properties put the mouse.sh file in.

then you're done.

  • 1
    12 as a device property will only work on your computer – Jonathan Jul 10 '17 at 20:50
  • To find out the id you need to use look at the output of the command xinput --list --short. – Paul Rooney Aug 28 '17 at 0:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.