1

I have recently purchased a ROG Falchion RGB wireless keyboard for use with my dual boot desktop (Win 10/Ubuntu 21.04). In Windows, using Armoury Crate, I have configured the lighting and set the power options for the keyboard to sleep after 2 minutes of idle time. What I have found is, when using Ubuntu, after the idle time has expired, instead of the keyboard going to sleep, the entire system goes into hibernation and the OS will restart unless you wake it and cancel the reboot. Currently, the only option to resolve the issue is to turn off the keyboard's power saving options in Armoury Crate. As this is not ideal, does anyone have any advice or thoughts on keeping power saving options on without causing the shutdown issues in Ubuntu?

3
  • That's a very strange problem, indeed. Sadly, there is no official support for Aura functionality on any Linux distribution right now besides a couple open-source alternatives and none of them directly manage power options. Your best bet right now would be to turn off the power saving options until better support is introduced into Xmodmap. A similar problem happens on ROG laptopts as well: linux.org/threads/keyboard-issues-with-asus-rog.34151 Jul 12, 2021 at 3:25
  • 1
    Thanks @AlexandreTeles. Turning off the power saving options seems to be the only way for now. I also found out if you turn off the keyboard with its on/off switch on the back, it will immediately trigger an OS shutdown.
    – sdk777
    Jul 12, 2021 at 23:37
  • I landed here because on Ubuntu, when the keyboards goes to sleep, it puts the machine to sleep as well. So funny.
    – user66081
    Dec 11, 2021 at 20:14

5 Answers 5

1

Disabling the xinput ID worked fine for me, too. However, the ID can change in certain situations, so I wrote a script to determine the correct ID before disabling it:

#!/bin/bash
IDENTIFIER="ASUSTeK ROG FALCHION System Control"

LINE=$(xinput list | grep "$IDENTIFIER")
ID=$(echo ${LINE#*id=} | tr '\t' ' ' | cut -d ' ' -f1)

if [ -n "$ID" ]; then
    xinput disable $ID
    echo "Disabled xinput ID $ID ($IDENTIFIER)"
else
    echo "No xinput ID for '$IDENTIFIER' found."
fi
0

For a more permanent solution, append the following config to /usr/share/X11/xorg.conf.d/40-libinput.conf:

Section "InputClass"
    Identifier         "disable asus falchioh sys control"
    MatchIsKeyboard    "on"
    MatchProduct       "ASUSTeK ROG FALCHION System Control"
    Option             "Ignore" "on"
EndSection
0

Issue resolved. ran the following:

#xinput disable XX

XX being the device id related to 'ASUSTeK ROG FALCHION System Control'

Also, created a startup script with this line

0

For a Wayland or system-wide fix you can use the hwdb snippet from my gist and follow the instructions. https://gist.github.com/jnettlet/afb20a048b8720f3b4eb8506d8b05643

1
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review Dec 11, 2021 at 8:40
0

One way that works is to make sure all the Power related keyboard shortcuts are disabled for your *Nix distro. Should be able to find them in your Settings. Works for Fedora 34 and 35 with my Falchion.

1
  • Can you expand on "find them in your Settings"? May 9 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.