6

I recently upgraded the kernel to version 5.13.0-051300-generic on my Tuxedo laptop equipped with Ubuntu 20.04. I am now trying to install the headers linux-headers-5.13.0-051300-generic_5.13.0-051300.202106272333_amd64.deb. If I try to do so with the command sudo apt install ./linux-headers-5.13.0-051300-generic_5.13.0-051300.202106272333_amd64.deb, I get the following error message:

The following packages have unmet dependencies:
 linux-headers-5.13.0-051300-generic : Depends: libc6 (>= 2.33) but 2.31-0ubuntu9.3 is to be installed
E: Unable to correct problems, you have held broken packages.

I then tried to install libc6_2.33-0ubuntu5_amd64.deb with the same command but get the following:

...
The following packages will be upgraded:
  libc6
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  libc-bin
1 upgraded, 0 newly installed, 68 to remove and 0 not upgraded.
Need to get 0 B/2,690 kB of archives.
After this operation, 2,034 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'

To which I stopped since I don't know what I'm doing exactly. I also tried the command sudo dpkg -i libc6_2.33-0ubuntu5_amd64.deb, and got the following:

dpkg: regarding libc6_2.33-0ubuntu5_amd64.deb containing libc6:amd64:
 libc6:amd64 breaks fakeroot (<< 1.25.3-1.1ubuntu2~)
  fakeroot (version 1.24-1) is present and installed.

dpkg: error processing archive libc6_2.33-0ubuntu5_amd64.deb (--install):
 installing libc6:amd64 would break fakeroot, and
 deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
 libc6_2.33-0ubuntu5_amd64.deb

I then tried to upgrade libfakeroot using the .deb file and GDebi (I also tried to install libc6 with this tool but the Install button is greyed out): if I check from the terminal the version of this library with apt-cache policy fakeroot I get Installed: 1.24-1 but if I check with sudo apt install ./libfakeroot_1.25.3-1.1_amd64.deb I get:

Note, selecting 'libfakeroot' instead of './libfakeroot_1.25.3-1.1_amd64.deb'
libfakeroot is already the newest version (1.25.3-1.1).

What am I doing wrong?


EDIT 1 The result of uname -a; ls /boot; apt-cache policy linux-headers-5.13.0-051300-generic linux-image-generic libc6 libc-bin libfakeroot is the following:

Linux lorenzo-InfinityBookS 5.13.0-051300-generic #202106272333 SMP Sun Jun 27 23:36:43 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
config-5.13.0-051300-generic  grub                              initrd.img-5.8.0-59-generic  System.map-5.13.0-051300-generic  vmlinuz-5.13.0-051300-generic
config-5.4.0-77-generic       initrd.img                        initrd.img.old               System.map-5.4.0-77-generic       vmlinuz-5.4.0-77-generic
config-5.8.0-55-generic       initrd.img-5.13.0-051300-generic  memtest86+.bin               System.map-5.8.0-55-generic       vmlinuz-5.8.0-55-generic
config-5.8.0-59-generic       initrd.img-5.4.0-77-generic       memtest86+.elf               System.map-5.8.0-59-generic       vmlinuz-5.8.0-59-generic
efi                           initrd.img-5.8.0-55-generic       memtest86+_multiboot.bin     vmlinuz                           vmlinuz.old
linux-headers-5.13.0-051300-generic:
  Installed: (none)
  Candidate: (none)
  Version table:
linux-image-generic:
  Installed: 5.4.0.77.80
  Candidate: 5.4.0.77.80
  Version table:
 *** 5.4.0.77.80 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/security.ubuntu.com/ubuntu focal-security/main amd64 Packages
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     5.4.0.26.32 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal/main amd64 Packages
libc6:
  Installed: 2.31-0ubuntu9.3
  Candidate: 2.31-0ubuntu9.3
  Version table:
 *** 2.31-0ubuntu9.3 100
        100 /var/lib/dpkg/status
     2.31-0ubuntu9.2 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
     2.31-0ubuntu9 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal/main amd64 Packages
libc-bin:
  Installed: 2.31-0ubuntu9.3
  Candidate: 2.31-0ubuntu9.3
  Version table:
 *** 2.31-0ubuntu9.3 100
        100 /var/lib/dpkg/status
     2.31-0ubuntu9.2 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
     2.31-0ubuntu9 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal/main amd64 Packages
libfakeroot:
  Installed: 1.25.3-1.1
  Candidate: 1.25.3-1.1
  Version table:
 *** 1.25.3-1.1 100
        100 /var/lib/dpkg/status
     1.24-1 500
        500 http://mirrors.tuxedocomputers.com/ubuntu/mirror/archive.ubuntu.com/ubuntu focal/main amd64 Packages
11
  • You have strange package versions in your question. Please clarify them. Edit your question to add the following uname -a; ls /boot; apt-cache policy linux-headers-5.13.0-051300-generic linux-image-generic libc6 libc-bin libfakeroot .
    – N0rbert
    Jul 10 at 18:55
  • "sudo apt install ./linux-headers-5.13.0-051300-generic_5.13.0-051300.202106272333_amd64.deb" Is the package already downloaded to your system? Please try: sudo dpkg -i linux-headers*.deb
    – chili555
    Jul 10 at 19:25
  • Did you have any problems with packages previously? Does tuxedo provide special packages? If no, I would recommend to use default normal Ubuntu mirrors like archive.ubuntu.com . How did you installed kernel at version 5.13.0-051300-generic and why?
    – N0rbert
    Jul 10 at 19:34
  • @N0rbert Tuxedo recommends installing a package of theirs and I guess after installing it these mirrors were added... I haven't had any issue before.
    – wrong_path
    Jul 10 at 19:35
  • @N0rbert I installed by downloading the .deb file if I remember correctly. Because I am having some issues installing a driver for a Ethernet-USB adapter.
    – wrong_path
    Jul 10 at 19:36
7

At first we need to revert packages to their default versions from Ubuntu 20.04 LTS repository:

sudo apt-get install --reinstall libc6=2.31-0ubuntu9.2 libc-bin=2.31-0ubuntu9.2
sudo apt-get install --reinstall libfakeroot=1.24-1

Then we need to remove just installed 5.13 kernel as its headers depend on newer libc6 which is not available for Ubuntu 20.04 LTS.

Use command below:

sudo apt-get purge linux-headers-5.13.0-051300 linux-image-unsigned-5.13.0-051300-generic linux-modules-5.13.0-051300-generic

About original USB-Ethernet problem with TP Link U300 I see that it is based on Realtek RTL8153. This chip is supported at least by linux-firmware package. But it hard to give complete instruction without the output journalctl -f and lsusb, lsusb -t.

2
  • 2
    So is it that we cannot install 5.13 on 20.04 altogether? Aug 19 at 6:22
  • Kernels from the mainline kernel ppa are not compatible with 20.04 anymore, see askubuntu.com/questions/1334633/…. If you need 5.13 there's now a version in the official repo called linux-image-oem-20.04c
    – barotto
    Aug 25 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.