Although my 2Tb USB3 HD connects to my L520 Lenovo laptop fine as USB2 on Windows, and I've successfully saved a small test file on it with Windows, it completely fails on my Ubuntu 20.04.2 LTS 64-bit Gnome 3.36.8. I've also tried it on Ubuntu 21.04 in LIVE DVD mode and it equally fails there.

Since it connects OK on my laptop's same USB ports on Windows, I think that rules out the obvious first suggestion of my Lenovo's USB ports being unable to deliver enough power for USB3.

Meanwhile USB2 HDs automatically mount and connect fine on Ubuntu, which points to an incompatibility between USB3 and Ubuntu

lsusb does detect my USB3 HD as Bus 001 Device 007: ID 152d:0562 JMicron Technology Corp. / JMicron USA Technology Corp.

but sudo gdisk /dev/sdb yields this doubtful response:

GPT fdisk (gdisk) version 1.0.5

Warning! Read error 5; strange behavior now likely!
Warning! Read error 5; strange behavior now likely!
Partition table scan:
  MBR: not present
  BSD: not present
  APM: not present
  GPT: not present
Creating new GPT entries in memory.
Command v [=verify disk] returns
No problems found. 3907029101 free sectors (1.8 TiB) available in 1
segments, the largest of which is 3907029101 (1.8 TiB) in size. 

Then gdisk yields:

gdisk : p
Disk /dev/sdb: 3907029168 sectors, 1.8 TiB
Model: Super Speed     
Sector size (logical/physical): 512/4096 bytes
Disk identifier (GUID): F0F1754E-D3FF-4D57-B00D-145653B40C51
Partition table holds up to 128 entries
Main partition table begins at sector 2 and ends at sector 33
First usable sector is 34, last usable sector is 3907029134
Partitions will be aligned on 2048-sector boundaries
Total free space is 3907029101 sectors (1.8 TiB)

Number  Start (sector)    End (sector)  Size       Code  Name

and parted yields:

sudo parted /dev/sdb
Warning: Error fsyncing/closing /dev/sdb1: Remote I/O error

I also tried Ubuntu Disks which shows 2TB block device /dev/sdb. Tried formatting sdb1 with Disks, but get Error wiping device: Failed to probe the device /dev/sdb1 (udisks-error-quark,0)

I've seen suggestions elsewhere about manually creating a mountpoint for this USB3 drive, but haven't followed them because I can't see why I should have to manually mount USB3 when USB2 drives mount automatically.

Appreciate any thoughts/suggestions

  • USB3 can have some issues with some disks. I'll elaborate more when I get closer to a proper answer. In the mean time, please update your question with this info: sudo lshw -C disk and grep -i sdb /var/log/syslog* and grep -i FPDMA /var/log/syslog*. If this info is lengthy, paste it to paste.ubuntu.com. Also screenshots of the Disks app SMART Data window. Does this external drive have it's own power brick? Is this a Western Digital drive internally?
    – heynnema
    Jul 8, 2021 at 23:11
  • And sudo blkid /dev/sdb*.
    – heynnema
    Jul 8, 2021 at 23:17
  • Status please...
    – heynnema
    Jul 9, 2021 at 13:45
  • Is fast boot disabled in windows? Please show lsusb
    – nobody
    Jul 11, 2021 at 0:14


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.