2

Flatpak apps such as Skype or Zoom do not detect my headphone microphone. If I start them with my headphones plugged in no microphone is detected, whereas if the headphones are unplugged the built-in microphone is detected. The headphone microphone does work elsewhere.

I tried running them with the --device=all argument but it doesn't seem to make a difference.

How can I troubleshoot this?

1

Try starting your app via the command line with the flag --socket=pulseaudio.

The functionality is not broken, it is intentionally denied access. Flatpak apps are extremely secure, often to the point of being nearly unusable. This security comes from running each app in its own sasndbox.

By default, This sandbox is cut off from almost access to the outside system. For more detail, and a few more methods of circumventing this behavior, see [here](Flatpak apps do not detect headphone microphone).

Honestly, this solution is a bit of a hail mary. If it doesn't work, try starting with the verbose flag. If you see anything about denied permissions for pulseaudio in the output, then it means that whoever packaged the app for flatpak did not build it properly.

In this case, access can only achieved by running with sudo, and that should be avoided with any app that sees the outside world, such as networking apps like yours. The better option would be to download via a different channel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.