I'm fairly new to Ubuntu, and this is the first time I've reached out and asked for help. Please let me know if you need any more information.

I did a clean install of Ubuntu 12.04 (64-bit) replacing Ubuntu 10.10 (32-bit) on my Samsung n150plus netbook last week.

Just before I did the install, we had a new router fitted with a new network and password etc.

My netbook worked fine with this router when it was using 10.10. But immediately after I installed 12.04, the SSID for that network was no longer detected. It does not come up in the list of available wireless networks.

However, if I use a wireless USB adapter/stick, it connects fine. The netbook's internal wifi also works when used with other wireless networks. But not with this one router.

Please let me know if I can give any more information that would help to solve the problem.

Some other details copied from comments

  • The router is a Virgin Media Super Hub (VMSH) made by Netgear.
  • My Samsung N150plus connects with no problem to other wifi networks. I appear to only have problems with this router.
  • I tried using a friend's Mac and it had no problem establishing a wifi connection to this router.
  • Do any other wireless routers/networks work correctly? Is the router displayed if you boot the Live CD or USB of an earlier Ubuntu release? Have you tried to manually add the router using "Edit Connections" in the network icon's menu? (Image in this answer provides an example of this menu.) – irrational John May 10 '12 at 23:10
  • thanks John. Other networks work fine. This network I want to use doesn't show up on my list of wireless networks. The router worked fine on my 32 bit Ubuntu 10:10. I forgot to mention that this is the 64 bit ubuntu 12.04. I don't know if that makes any difference.. I did try to add the router manually, including the ssid. I wasn't sure what else to add, and this didnt make any difference. – vlad May 12 '12 at 0:58
  • Can other computers (or operating systems) see the SSID of this network and connect to it? Just trying to rule out the possibility of a router problem coincident with your install of 12.04. – irrational John May 12 '12 at 1:21
  • yes, my girlfriend's mac has no problem connecting to that particular network. It is recognised and can be connected to – vlad May 12 '12 at 12:51
  • So what is different between routers/networks where your netbook wi-fi works and this one? – irrational John May 12 '12 at 13:04

Upgrade kernel and then see the results. Ubuntu 12.04 comes with kernel 3.2. I have upgraded to 3.4 kernel.

  • You may want to edit this answer to explain some of the potential dangers in upgrading the kernel to 3.4 (so people who follow this answer are prepared), explain how to upgrade it (or link to something that does), and explain as best you can why upgrading it will help in this situation. – Eliah Kagan Jul 15 '12 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.