Though I have gone through quite a few threads on AskUbuntu, I couldn't find a proper way to disable these Evolution services, especially when Evolution is purged from the system already, in Ubuntu MATE 21.04.

These services are not listed under systemctl list-unit-files --type=service, so I can't use sudo systemctl mask.

ps -ef | grep evolution

admn 1973 1459 0 17:15 ? 00:00:00 /usr/libexec/evolution-source-registry
admn 2023 1459 0 17:15 ? 00:00:00 /usr/libexec/evolution-calendar-factory
admn 2058 1459 0 17:15 ? 00:00:00 /usr/libexec/evolution-addressbook-factory

These 2 Evolution related packages are still there, because purging them would remove a lot of other packages.


Result of ls -lsh /usr/libexec/evolution*:

$ ls -lsh /usr/libexec/evolution*

 16K -rwxr-xr-x 1 root root  15K Jun 22 20:57 /usr/libexec/evolution-addressbook-factory
 48K -rwxr-xr-x 1 root root  47K Jun 22 20:57 /usr/libexec/evolution-addressbook-factory-subprocess
116K -rwxr-xr-x 1 root root 115K Jun 22 20:57 /usr/libexec/evolution-calendar-factory
136K -rwxr-xr-x 1 root root 135K Jun 22 20:57 /usr/libexec/evolution-calendar-factory-subprocess
 60K -rwxr-xr-x 1 root root  59K Jun 22 20:57 /usr/libexec/evolution-scan-gconf-tree-xml
124K -rwxr-xr-x 1 root root 123K Jun 22 20:57 /usr/libexec/evolution-source-registry
 20K -rwxr-xr-x 1 root root  19K Jun 22 20:57 /usr/libexec/evolution-user-prompter

total 116K

 32K -rwxr-xr-x 1 root root  31K Jun 22 20:57 addressbook-export
8.0K -rwxr-xr-x 1 root root 7.0K Jun 22 20:57 csv2vcard
 52K -rwxr-xr-x 1 root root  51K Jun 22 20:57 evolution-alarm-notify
 24K -rwxr-xr-x 1 root root  23K Jun 22 20:57 list-sources

OS: Ubuntu MATE 21.04

evolution-data-server: 3.40.0-1ubuntu1.1

evolution-data-server-common: 3.40.0-1ubuntu1.1

Thanks a lot in advance.

  • 1
    Does this answer your question? How to stop evolution-alarm-notify
    – N0rbert
    Jul 6, 2021 at 18:49
  • @n0rbert As I have mentioned in my question, when I try: systemctl status evolution-addressbook-factory.service, I'm getting this message: Unit evolution-calendar-factory.service could not be found. Thanks.
    – Jags
    Jul 6, 2021 at 19:00
  • You have to pass --user to systemctl. All these units are owned and started by user session.
    – N0rbert
    Jul 6, 2021 at 19:11
  • @n0rbert Ahhh that's why I was not able to find these services. So I should just systemctl --user mask these 4 services: evolution-addressbook-factory.service, evolution-calendar-factory.service, evolution-source-registry.service, evolution-user-prompter.service or do I need to copy .desktop to ~/.config/autostart/ as mentioned in the link you've posted? Many thanks.
    – Jags
    Jul 6, 2021 at 19:18
  • @n0rbert Also, would you like to post an answer please? Because the other thread you have mentioned is mainly about evolution-alarm-notify... the issue I do not have. I think an answer here would help any future visitor that because of the lack of --user to systemctl was the cause of not finding these services. Thanks again.
    – Jags
    Jul 6, 2021 at 19:29

2 Answers 2


So let's start from the beginning. On the fresh Ubuntu MATE 21.04 I have:

$ ps -ef | grep evolution | grep -v grep
h           2025    1612  1 22:32 ?        00:00:00 /usr/libexec/evolution-data-server/evolution-alarm-notify
h           2112    1595  1 22:32 ?        00:00:00 /usr/libexec/evolution-source-registry
h           2230    1595  1 22:32 ?        00:00:00 /usr/libexec/evolution-calendar-factory
h           2250    1595  1 22:32 ?        00:00:00 /usr/libexec/evolution-addressbook-factory

$ systemctl list-units --type service --user | grep evolution
  evolution-addressbook-factory.service loaded active running Evolution address book service
  evolution-calendar-factory.service    loaded active running Evolution calendar service
  evolution-source-registry.service     loaded active running Evolution source registry

To disable parts of Evolution Data Server one should disable systemd user services by:

systemctl --user mask evolution-addressbook-factory.service
systemctl --user mask evolution-calendar-factory.service
systemctl --user mask evolution-source-registry.service
systemctl --user mask evolution-user-prompter.service

and reboot.

If you want to take radical measures then use below command

sudo apt autopurge evolution-data-server

to remove the package providing above systemd units.

Also please note that removing of remaining three packages named evolution-data-server-common, libecal-2.0-1:amd64 and libedataserver-1.2-26:amd64 will remove ayatana-indicator-datetime. So the resulting system will not have Calendar on the MATE Panel. Do not remove these 3 packages listed above.

  • systemctl --user mask 4 services solves the issue. For now, I'm not purging evolution-data-server or other 3 packages you have listed, as I do want to keep ayatana-indicator-datetime working in MATE. As always thank you so much :)
    – Jags
    Jul 6, 2021 at 19:47

Evolution-data-server (EDS) was --long ago-- an outgrowth of Evolution. However, EDS is not part of Evolution; they are separate. Only the name remains.

EDS is part of a stock install of Ubuntu, and should remain on your system whether or not you choose to install or use Evolution.

EDS handles your unified calendar and addressbook for the for your Desktop session. Most Desktop users should leave it in place and let it do its job.

  • I'm sorry to say your answer narrowly focuses on Evolution name and does not focus on disabling three services I have listed in my question. Thanks.
    – Jags
    Jul 6, 2021 at 18:56
  • I'm sory but you said, "Most Desktop users should leave it in place and let it do its job."... if that was the case.. I would be using Microsoft Windows.
    – Jags
    Jul 6, 2021 at 18:56
  • 1
    Most folks who ask this kind of question are confused. They think the services are part of the Evolution groupware suite. They are not. Then the same folks get all frizzed up when applications can't find the calendars and contacts and other data they expected to be there. If you are not among that common set, you should edit your question to make clear that you fully understand the consequences of what you are asking for.
    – user535733
    Jul 6, 2021 at 19:05
  • If my question is not "crystal clear" enough to you... I'm sorry I do not have to say anything further to you.
    – Jags
    Jul 6, 2021 at 19:07
  • Okay. Have a nice day.
    – user535733
    Jul 6, 2021 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.