0

I have installed a fresh version of Ubuntu 20.4 on my band new Asus Tuf Dash F15 laptop. Then I went into the software update settings and switched the driver to nvidia-460 proprietary using the GUI. I apply the changes and restart and I get stuck at a boot loading screen. The error is /dev/nvm1e0 clean: xxxblocks/xxx.

Specs: Nvidia RTX 36060 mobile Intel i7 40gb ram 1tb storage

I have tried installing the nvidia drivers 4 different ways, according to the nvidia official installation guide and multiple medium forums. Every time I get the same problem and have to alt+shift+f2 my way into the terminal to sudo apt-get purge nvidia* to be able to boot back in.

I've installed nvidia diver on ubuntu many other times according to the nvidia official docs and never ran into this error. I am concerned it may be hardware incompatibility at this point?

I've been trying for three days now and re-installed ubuntu multiple times, varying the partitions and installation methods. Everything is working fine until I try and switch to nvidia driver. I even tried some older and new driver versions and the nvidia cuda toolkit 10 and 11. Please help, thank you.

6
  • hi @Yume. have you checked this askubuntu.com/questions/1311476/… and this linuxconfig.org/…?.
    – jpbrain
    Jul 6 at 4:46
  • Also. There is another recommendation to set "intel_idle.max_cstate=1" in grub boot command line.
    – jpbrain
    Jul 6 at 4:57
  • @jpbrain This is literally one of the methods I've already tried to install Nvidia driver, does not work. How do you set intel_idle.max_cstate=1?
    – Yume
    Jul 6 at 14:35
  • you need to edit /etc/default/grub and add that text to GRUB_CMDLINE_LINUX_DEFAULT, and the update-grub. Also, Have you checked if there is a Bios update also?. I use a different ASUS TUF F15 (not dash), but do not have that problem.
    – jpbrain
    Jul 6 at 15:50
  • @jpbrain did as you said, rebooted, then installed driver according to the link you gave, now I cant boot at all. It starts up like normal and then just stops after Started Daemon for power management. There is just that text, black screen, and blinking dash curser. ;[
    – Yume
    Jul 6 at 23:56
0

I encountered the same problems with a machine with the same specs as yours attempting to boot a clean install of Ubuntu Studio 20.04. Worked fine until I installed the native Nvidia drivers. Same symptoms with the a black screen after the Asus splash screen. I was able to fix the issue by doing the following steps (not sure all of these are needed, but it's what worked for me):

  • Update the BIOS for the Tuf book to latest (version 309).
  • Remove the Windows boot drive and install a 1 TB blank drive.
  • Install PopOS 20.04 LTS using the installer with the Nvidia drivers.

I think that last step is the one that got it working. I verified I have the proprietary Nvidia drivers installed (Driver Version: 465.31 ) on Pop OS 20.04 and it's booting correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.