1

This is not a duplicate question, I've followed the steps in the similar question that was posted on Ubuntu v. 18.04, but no solutions worked.

despite doing sudo dpkg --add-architecture i386

this is returned when I try to install i386 packages or after updating the list.

E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/hirsute-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.38 80]
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/hirsute-updates/main/binary-amd64/Packages  404  Not Found [IP: 91.189.91.38 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.```
3

2 Answers 2

0

I think you have an arm system.

i386 and amd64 are not at http://ports.ubuntu.com; They're are at http://archive.ubuntu.com/

0

From: https://wiki.debian.org/Multiarch/Implementation

To enable the installation of multiarch binaries, apt and dpkg need configuration changes. For example, if you have an amd64 system that you want to install i386 libraries onto, do the following:

  • multiarch support is present from dpkg 1.16.2 (or 1.16.0 in Ubuntu) and apt 0.8.13.
  • run dpkg --add-architecture i386
  • run apt-get update to refresh the package cache with the newly added architecture
  • to delete i386 run dpkg --remove-architecture i386
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.