1

i am a new user in ubuntu and i am unable to install my wifi adapter driver i.e of adnet 802.11n please help i had uninstalled my previous windows os

1
  • 1
    Let's start by identifying your exact device. Insert the device and run this terminal command: lsusb. Next, edit your question to add the result. Welcome to Ask Ubuntu.
    – chili555
    Jul 4, 2021 at 1:38

2 Answers 2

1

Just a shorter version from the GitHub link given in the detailed answer by @Vashishth Patel that worked for me is:

sudo add-apt-repository ppa:kelebek333/kablosuz
sudo apt update
sudo apt install rtl8188fu-dkms
0

First check your usb configuration by typing "lsusb" in your terminal and check it.. see the image for more info..

1

If your usb configuration is this "0bda:f179" Than you can try this following commands...

install :

sudo apt-get install build-essential git dkms linux-headers-$(uname -r)

git clone https://github.com/kelebek333/rtl8188fu

sudo dkms add ./rtl8188fu

sudo dkms build rtl8188fu/1.0

sudo dkms install rtl8188fu/1.0

sudo cp ./rtl8188fu/firmware/rtl8188fufw.bin /lib/firmware/rtlwifi/

Run following commands for disable power management and plugging/replugging issues:

sudo mkdir -p /etc/modprobe.d/

sudo touch /etc/modprobe.d/rtl8188fu.conf

echo "options rtl8188fu rtw_power_mgnt=0 rtw_enusbss=0" | sudo tee /etc/modprobe.d/rtl8188fu.conf

How to uninstall :

sudo dkms remove rtl8188fu/1.0 --all

sudo rm -f /lib/firmware/rtlwifi/rtl8188fufw.bin

sudo rm -f /etc/modprobe.d/rtl8188fu.conf

1
  • Please be aware that installing the wrong driver can rise future compatibility issues with OP devices. Providing a more general answer would be preferred, as well as waiting for OP to provide more information about their hardware. Jul 12, 2021 at 3:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.