1

I just installed Epson M100. The driver comes from their website. I can print the test page with no problem.

But when I try to print in LibreOffice Writer and or Calc, I only got blank page.

I also tried to export the document into PDF but the PDF file is also blank.

I also tried printing in firefox web browser and it prints fine.

How do I troubleshoot?

Thanks

2 Answers 2

2

There is a known issue in LibreOffice due to an bug in the Qt5 toolkit used by the LTS release of Ubuntu 20.04 LTS [5.12.8]. It only impacted Qt5 users (ie. Lubuntu using LXQt & Kubuntu using KDE).

It is documented in the Lubuntu 20.04 release notes, see

or on LibreOffice questions, see

The Qt5 toolkit used in 20.04 is the LTS version (5.12) and the issue doesn't exist in later releases.

You can install a snap version (which will use later libraries packaged within the snap), remove Qt5 libs and use GTK3 ones (as used by main Ubuntu and other flavors), or use the work around provided at the Lubuntu site; see

ie.

The solution is to go to Preferences-LXQt settings-Session settings - Environment variables - Environment (advanced) - then add the following 2 variables if they are missing -

SAL_USE_VCLPLUGIN qt5
SAL_VCL_QT5_USE_CAIRO true
1
  • 1
    There has to be a duplicate of this - but I cannot find it sorry.. I know I've written this many times (though maybe elsewhere [UF etc] or maybe it's b/c I'm nearly always just commenting the links & don't answer.)
    – guiverc
    Jul 3, 2021 at 5:57
1

tl:dr: try a different font type

I have this same issue running KDE Plasma.

As @guiverc insightfully mentioned:

It is documented in the Lubuntu 20.04 release notes, see

When I visited the known issues link, more details are provided. To quote directly from that page:

LibreOffice Exporting Documents as a PDF

There is a bug where certain fonts do not render in exported PDF documents. As a workaround, LibreOffice applications can be launched from the commandline with the following environment variable SAL_VCL_QT5_USE_CAIRO=true. For example, to launch writer issue SAL_VCL_QT5_USE_CAIRO=true libreoffice –writer.

To emphasize in the first sentence there, it explains that the issue is with "certain fonts". In my case, I was using "Cantarell". I changed the font type to "Hack" and presto! My Libreoffice Writer and my HP printer started printing properly. The pages are no longer blank and the content is printing as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.