4

Since I have make the new Ubuntu update, I have a black screen when I start my HP laptop (11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz × 8 ) with a Intel iRIS xe GPU.

The only solution that I have find until now to work with my laptop is to put the "nomodeset" command in the grub but with this option, linux don't used the Intel vendor driver and the driver that I can see in my config is a "llvmpipe (LLVM 12.0.0, 256 bits)"

I have reinstall my laptop one time with Secure Boot and one time without but I have always the same issue. I have try other solution like the "oibaf" drivers but always the same issue.

Here are info :

uname -r 
5.11.0-22-generic

lspci -nnk | grep -iA2 VGA
0000:00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake GT2 [Iris Xe Graphics] [8086:9a49] (rev 01)
    DeviceName:  Onboard IGD
    Subsystem: Hewlett-Packard Company Iris Xe Graphics [103c:87fe]

inxi -G
Graphics:
  Device-1: Intel TigerLake GT2 [Iris Xe Graphics] driver: N/A 
  Device-2: IMC Networks HP TrueVision HD Camera type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.11 driver: loaded: fbdev 
  unloaded: modesetting,vesa resolution: 1920x1080~77Hz 
  OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) 
  v: 4.5 Mesa 21.2.0-devel (git-25ad699 2021-07-02 hirsute-oibaf-ppa) 

lshw -c video
*-display NON-RÉCLAMÉ     
       description: VGA compatible controller
       produit: TigerLake GT2 [Iris Xe Graphics]
       fabricant: Intel Corporation
       identifiant matériel: 2
       information bus: pci@0000:00:02.0
       version: 01
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pciexpress msi pm vga_controller bus_master cap_list
       configuration : latency=0
       ressources : mémoireE/S:600-5ff mémoireE/S:400-3ff mémoire:6002000000-6002ffffff mémoire:4000000000-400fffffff portE/S:4000(taille=64) mémoire:c0000-dffff mémoire:4010000000-4016ffffff mémoire:4020000000-40ffffffff

Without this drivers, I can't change the brighthess of my screen and everybody is a little bit to dark for me :-)

Can somebody help me ?

Thanks you

Jean-Marc

3
  • Same issue here Aug 15 at 12:59
  • Did you find a solution for this? Same issue on i7-11800H (Dell xps 15 9510). Error message: ERROR CPU pipe A FIFO underrun
    – David Roth
    Aug 31 at 9:15
  • LG Gram with Intel Iris Xe graphics installed 21.10 with no issues.
    – Rinzwind
    Oct 5 at 17:40
2
+25

The Intel Iris Xe Graphics is reportedly having issues, which are yet to be resolved.

Possible solutions

  1. Disable Secure Boot in the BIOS.
  2. Update the kernel to the latest 5.11-....
  3. Install OEM kernel with sudo apt install linux-oem-20.04c && sudo reboot 0.
  4. Build a newer kernel, YMMV.

I am not sure which of these options takes full advantage of both graphic units.

See this related answer. It deals with a related (although not necessarily the same) problem.

Further info

Please post the output of

$ uname -a 
$ lsb_release -a
$ dmesg | grep drm 
$ sudo lshw -c video                        <-- DONE
$ glxinfo -B
$ hwinfo --gfxcard
$ sudo update-pciids
$ lspci -v | egrep -i --color 'vga|3d|2d'
$ mokutil --sb-state

If you don't have some of these programs, simply install them with sudo apt install <package name>.

Related:

  1. https://techstoriesindia.in/2021/07/my-experience-with-installing-ubuntu-on-acer-iris-xe-max-laptop/
  2. get back MOK management screen on dual boot install (do not want to disable secure boot)
  3. System is unusable after upgrade to 20.10 - i915 GPU hang
  4. UnclaImed display in ubuntu 21.04 with Rocket Lake
3
  • Original post referred to (non-existing) linux-oem-21.04. Fixed that to linux-oem-20.04c. Removing this comment shortly. Aug 17 at 11:57
  • Thanks! Tried solution 1-3 and also tried upgrading to 21.04 with no luck - so doing my work with WSL2 for now. Unrelated but, any tips on how to avoid hardware issues like this when buying a new laptop that you're going to install Ubuntu on? Aug 18 at 7:59
  • @LeonardusChen - I suggest you go over commands listed, one by one, and post the exact output in text format (not screen capture) in the OP. That is the best way to solve the problem. As for how to avoid them when buying a new laptop... just do the research. Get the specs (audio, video, bluetooth, network, etc.) and google with a few parameters like Ubuntu, issue, <your device exact brand/model>, etc. Aug 18 at 10:07
0

I ran into video issues this week with an 11th Gen Intel® Core™ i7-1165G7 when my Ubuntu Mate 20.04 upgraded the Linux kernel to 5.11 . I could not use the UI at all and had to rely on the standard terminal to view logs. The error that stood out was a *ERROR* CPU pipe A FIFO underrun in the dmesg.

Similar, the video issues went away when using nomodeset at the expense of losing functionality since it instructs not to load any video drivers.

I downgraded the kernel back to 5.8 and things started to work again properly. So that's my feasible workaround for the moment so I can continue doing my work. I do eventually want to upgrade again to a newer kernel, but haven't yet tried troubleshooting it properly. I did read something about forcing the kernel to probe for the GPU e.g.i915.force_probe=..., but not sure if that's relevant or not.

5
  • Did you find a solution for this? Same issue on i7-11800H (Dell xps 15 9510)
    – David Roth
    Aug 31 at 9:13
  • No, not yet. I've kept with Ubuntu 20.04 LTS on Wayland and Linux 5.8 to make use of the GPU. When using X11 it defaults to LLVMpipe, but on Wayland I'm able to use the proper driver. I do have other projects to work on so I'll be waiting to test again on Ubuntu 21.10 (think it'll be Linux 5.14) Sep 1 at 18:28
  • I take it back, I did try i915.force_probe=, but it's no longer an option that can be used in newer kernels (think it was deprecated a while ago) so no luck there Sep 1 at 18:30
  • Following up with Ubuntu 21.10. I upgraded today (installed Linux 5.13). Same issue occurred so switched the kernel back to 5.8 to use Ubuntu 21.10. I've also tried 5.14.12 and the latest RC of 5.15 and it only made things worse (could not boot up). Anyhow, long story short, I found that I can use 5.13 if I disable Intel's Panel Self Refresh technology by adding to my "GRUB_CMDLINE_LINUX_DEFAULT" i915.enable_psr=0. Regarding power consumption, I haven't noticed a hit. Still float around the usual 8W-12W web browsing on the laptop. Issue not fully resolved, but hope the workaround helps. Oct 15 at 22:30
  • Sultan Alsawaf gives a better explanation of the issue: lkml.iu.edu/hypermail/linux/kernel/2003.3/07303.html Oct 15 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.