4

Yesterday I finally updated Ubuntu to 21.04 from 20.10. The update went well, but after a reboot the system was stuck on my motherboard's splash screen.

I've noticed that in grub, I have two kernels to choose from:

5.11.0-22-generic

and

5.8.0-59-generic

When I pick the second one, the system boots, but everything's kind of weird and glitchy. But it worked well enough for me to open the driver settings, and switch to nouveau.

With nouveau, everything works well with the default kernel, except that I can't play demanding games, so I'd definitely prefer to use nvidia's driver.

Switching to nvidia's driver makes the problem appear again, no matter which version I choose (the default is 460 but I tried other ones too).

Out of curiosity, I tried a Manjaro Live CD which can boot with proprietary drivers, and it had a similar problem. It gets stuck while booting, but when I boot with open source driver, it works. So maybe it's something to do with the kernel, and nvidia's driver? Is it a known problem? I have a RTX 2060 video card.

3
  • Did you try the 465 driver? It's now in the standard repos, but not the recommended one yet.
    – ubfan1
    Jul 2, 2021 at 23:31
  • Thanks for the reply! I've tried it, and some other driver versions in the repo, but none of them worked.
    – Meeep
    Jul 4, 2021 at 15:12
  • I had similar problem but for me it didn't work even under noveau. I had to reinstall. Try looking at your boot log journalctl --boot=-1 or the x server log
    – rattkin
    Jul 7, 2021 at 13:09

0

You must log in to answer this question.

Browse other questions tagged .