I have a fresh installation of Ubuntu 12.04, I have been running it for about a week. Suddenly today I noticed my computer freezes every 5 seconds. I restarted the computer and I still get this. I believe it is a process called watchdog/0 that is using all the resources. See the attached pictures.

How can I stop this? I can barely use my computer like this.

see CPU hits 100% when idle it is the watchdog process


Well I just did a cold reboot, (shutdown, unplug, and plug back in, and turn on) and it seems to have fixed it. After looking at the man page for watchdog, it seems that this process may stay on during a restart? so it is more like a soft restart? Why that happens I don't know.


Here's a quick summary of what it does:

The watchdog program writes to /dev/watchdog every ten seconds. If the device is opened but not written to within a minute, the machine will reboot. This feature is available when the kernel is built with ‘software watchdog’ support (standard in Debian kernels).

While it may seem useful, it's not really that crucial for your system's reliability, moreover it tends to cause unnecessary wakeups which in turn may lead to shorter battery performance/ You can easily disable it by adding nmi_watchdog=0 to your kernel boot parameters in /etc/default/grub.

| improve this answer | |
  • Thanks that sounds like a good solution. I wonder why it was eating all the CPU usage every few seconds? – jeffery_the_wind May 10 '12 at 10:44
  • Did not work for me, unfortunately. Watchdog is still there, after adding the line to /etc/defaults/grub. – twigmac Mar 18 '14 at 15:29
  • I think it should be /etc/default/grub? – Mark E. Haase Mar 28 '16 at 1:26

My server is a Dell R320, 12 cores, watchdog drain CPU heavily, avg. 68% CPU usage.

Add following drivers to blacklist configuration file /etc/modprobe.d/blacklist.conf fixed my problem

blacklist acpi_pad
blacklist mei
blacklist sb_edac
blacklist i7core_edac
| improve this answer | |

This could be related to https://bugs.launchpad.net/ubuntu/+source/watchdog/+bug/1010855 or https://bugzilla.kernel.org/show_bug.cgi?id=42981

On my system, rebooting works around the issue, but it comes back after a few hours.

| improve this answer | |
  • Further news on this issue: when I upgraded the kernel on the system in question (a Dell R720 with 16 cores) to 3.8.0-31.46~precise1 (tip: use package linux-image-generic-lts-raring), the problem went away. – Paul Gear Oct 18 '13 at 11:07
  • Actually, it looks like linux-image-current-generic might be a better long-term choice, since it doesn't depend on the name of the current release. – Paul Gear Jan 22 '14 at 2:45

I was able to tranquilise the watchdog by stepping down with the kernel version. Therefore I had to make the grub menu visible as described in this Q&A.

After choosing an earlier kernel during startup, the watchdog was calm. However, then rtkit-deamon went totally crazy eating the same amount of the CPU as the watchdog did before.

| improve this answer | |

Following this link http://osdir.com/ml/ubuntu-bugs/2013-08/msg09026.html i did following:

1) deleted (after backing up) /lib/modules/3.13.0-24-generic/kernel/drivers/char/ipmi/ipmi_watchdog.ko

2) commented out line in /boot/config-3.13.0-24-generic with "IPMI" and "watchdog" in it

And now the problem seems to be gone.

Note you may need to change the kernel version from 3.13.0-24-generic using the uname -r command in terminal to get the current in use kernel.

| improve this answer | |

I tried @feifan.overflow answer, but not worked, maybe I need to reboot it to apply the changes.

The command below worked for me.

I am running a Debian Wheezy on a Dell PowerEdge (seems to be some incompatibility)

rmmod acpi_pad
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.