Using GNOME Mplayer everytime I play a video, I get the annoying dialog pop-out in the screenshot below.

alt text

10 Answers 10


I'm using the proprietary NVIDIA driver and I fixed this by creating a symlink to the VDPAU lib:

ln -s /usr/lib/vdpau/libvdpau_nvidia.so.1 /usr/lib/libvdpau_nvidia.so

This has the benefit of actually enabling VDPAU rather than falling back to XV or X11. Of course you need a video card that supports VDPAU acceleration.

| improve this answer | |

You can suppress all dialogues like this in mplayer variants by editing ~/.mplayer/config in the editor of your choice and somewhere in the file including really-quiet="1". I use plain mplayer (no GUI at all) but that shouldn't change things, this worked for me in GMplayer too. Here's my config:



You probably don't want the vo and vc lines (I'm a Nvidia user) and you might not want any of the other settings. If I were you, I would just use this:

| improve this answer | |
  • thanks there, but I am still newbie here, I know nothing bout those config – ok comp Nov 16 '10 at 15:56
  • @ok Press Alt+F2 and stick bash -c "mkdir -p ~/.mplayer; gedit ~/.mplayer/config" in there and hit Run. In the next window that pops up, copy in my second block of code (the 3-line-long one). Click save, close gedit and then run mplayer. – Oli Nov 16 '10 at 16:03

For Intel VGA, and x64 I have solved it with

sudo apt-get install i965-va-driver
sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install libvdpau-va-gl1
cd /usr/lib/x86_64-linux-gnu/vdpau/
sudo ln -s libvdpau_va_gl.so.1 libvdpau_i965.so.1

For Nvidia the package are

sudo apt-get install libvdpau1 vdpau-va-driver
| improve this answer | |
  • line 2 "sudo add-apt-repository ppa:nilarimogard/webupd8" might be not needed on later releases, but rest of it solved my problem. – silpol Apr 19 '18 at 7:49

Here is the solution to your problem:

Just try specifying a video output driver on the command line when you launch mplayer like this:

mplayer -vo xv video.wmv

You can get a list of "Available video output drivers" with the command mplayer -vo help.

The problem is that the selected (or default) video output driver was vdpau, and no one working on the mplayer packages and software cares enough about having the software package work with your configuration of hardware and software. But do not worry, you are now blessed with this answer, and the video output driver can be specified on the command line (e.g. -vo xv).

The order of configuration options that mplayer will scrawl before it finally decides to (only) try the (missing) vdpau driver is not so obvious, but I think it roughly goes like this,

  1. Check the ~/.mplayer/config for the (user specific) default video output driver, if any
  2. Then check /etc/mplayer/mplayer.conf for the (system specific) default video output driver, if any
  3. Then check in the compile options that mplayer was built with for a default (build specific).

If the mplayer command you were using was compiled with the vdpau option and there are no default video output drivers specified in ~/.mplayer/config or /etc/mplayer/mplayer.conf (which is either a common occurrence or I am the only person on the planet earth who has ever had problems with a configuration option on a linux box) then it will fall back to the compiled default which in this case was vdpau.

Another similar issue is that mplayer may work fine while gmplayer gives this same error using the same options you just tried with mplayer. Well guess what? gmplayer uses yet another config file, ~/.mplayer/gui.conf, and it will default to the last video driver specified (or defaulted to in the compile options). So again, just specify a video output driver on the command line, or put one in one of the myriad of config files mentioned here.

| improve this answer | |
  • thanks there, but I am still newbie here, I know nothing bout those config – ok comp Nov 16 '10 at 15:56
  • FYI, I dont have those graphic card but only the integrated one. mine is compaq cq20-213TU – ok comp Nov 16 '10 at 15:57

add -vo xv

enter image description here

| improve this answer | |

However, a little setting can sort out the problem as follows;

  • Open Edit → Preferences in the GNOME Player menubar
  • Select the "Player" tab
  • Select x11 for the Video Output
  • Close preferences and try to open the video file again.

Your problem should have been resolved.

| improve this answer | |
  • I strongly recommend not to use x11, for it's the least performant output driver. Use xv (x11 video extension) or gl/gl2 (opengl) instead. These should give decent performance. – soulsource Jun 20 '12 at 17:42

Note: Everything before update was included because it may be useful for someone else, and was posted written either before testing or when I was lacking info on the situation.

If you are using an nVidia card, install the proprietary drivers.

Fglrx is the official (closed source) ATI/AMD driver, though there are also official open source drivers included in Ubuntu by default, and these work just as well with many (older, usually) cards. vdpau (sorry if I misspelled earlier) is only currently available on nVidia and (to my knowledge) Intel cards. MPlayer supports this API for video acceleration, but it is not needed to play videos. As I am not an avid MPlayer user (I use Totem or VLC Media Player to play videos and DVDs), I will have to do some more digging for the correct entry in the configuration file.

I would not suggest compiling the libvdpau.so file, as it would quite honestly be useless in your configuration, and if you were to get an nVidia card with the proprietary drivers you would not need to install anything extra anyway.

One suggestion I would give you is to install MPlayer-gui Install mplayer-gui (temporarily) and see if when launching this allows you to disable the use of vdpau from the gui options. Then you could revert to the normal MPlayer and it should work without any further problems. If that doesn't work, then you might have to end up compiling :( to disable the use of vdpau (and to avoid having to buy a new graphics card lol).


Don't laugh, (okay, laugh at me, go ahead ;) - but I just opened Gnome-MPlayer for myself and in preferences, you can choose your video output module! All you need to do now is to choose one that works for you (vaapi should work on your graphics card).

Under the MPlayer tab (not shown), you can also add command line parameters to pass to MPlayer just in case.

screenshot screenshot screenshot! omg! lol! lol? ohwell...guess it didn't load?

Customary screen-shot :)

The Wikipedia page for vaapi should help you to understand most of the video acceleration methods in detail (if you follow the links recommended in the article).

| improve this answer | |
  • @Roland: Thanks! But I can call Gnome Mplayer on the avi file without error from terminal. I think this means my OS already has the necessary drivers. Right? – Tim Mar 13 '11 at 19:24
  • @Tim it probably has the drivers it needs, but not the libvdpua library, which is provided by nVidia's own driver as opposed to the open source drivers. If you install these drivers, it should work. – RolandiXor Mar 13 '11 at 19:32
  • @Roland: Thanks! I just downloaded libvdpau-0.4.1.tar.gz from cgit.freedesktop.org/~aplattner/libvdpau . I tried to install it by "./configure, make and make install", but "./configure" is not there, instead it has ./configure.ac and ./Makefile.am. How can I install libvdpau then? – Tim Mar 13 '11 at 19:44
  • @Tim with that particular tarball, you have to run ./autogen.sh first, then ./configure --prefix=/usr, make and sudo make install. However, I caution you that this may not create the .so with the same name that mplayer is requesting, so you would have to locate and rename the file. This is why I strongly suggest you use nvidia's drivers (just run jockey-gtk to see if you can install them). – RolandiXor Mar 13 '11 at 19:48
  • @Roland: Thanks! I just run jockey-gtk, but there was only one driver available, which was ATI?AMD proprietary FGLRX graphics driver. I installed it anyway. Now the problem "Gnome Mplayer failed to open VDPAU backend libvdpau_nvidia.so" still persists with the original command is "gnome-mplayer %U ". – Tim Mar 13 '11 at 20:09

Right click the Application icon and select Edit Menus, select the menu item for mplayer and edit the Properties > Command

| improve this answer | |
  • Thanks! The original command is "gnome-mplayer %U ". I was wondering what does "%U" mean? Also "gnome-mplayer %U -vo xv" does not work. – Tim Mar 13 '11 at 3:16

This command line helped me: mplayer -demuxer mov filename.mov

| improve this answer | |

Installing libvdpau-va-gl solved it for me, but it was a software solution. Try setting export VDPAU_DRIVER=nvidia

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.