I've been struggling with wake-on-lan (WoL) capability of my onboard Realtek RTL8111/8168B ethernet controller (MB: Gigabyte Z68AP-D3) for almost a week now. The main issue seems to be that network card is switched off completely during shutdown (i.e., both link and (act)ivity LED lights are off).

I made an extensive review of similar issues and tried the following (among others):

  • Putting ethtool -s eth0 wol g to rc.local file.
  • Installing latest r8168 driver(s) from Realtek.
  • Putting echo -n "my_lan_id" >> /proc/acpi/wakeup to rc.local file.
  • Switching WOL option on and off in BIOS.

I can find no way to prepare my NIC to work properly so I decided to try with external PCI network card. Please suggest me which network card should I try to enable WoL? (Maybe Intel® PRO/1000 GT Desktop Adapter?)

  • Looks like I have an identical problem after 12.04 upgrade :( – Adam May 11 '12 at 0:17
  • @Adam, what hardware (motherboard and network controller) do you have? BTW, I tried with two Ubuntu 12.04 laptops (T520 and HP ProBook 4530s) yesterday and WoL works out of the box. – Andrej May 11 '12 at 4:34
  • It's a "RTL8111/8168B PCI Express Gigabit Ethernet controller" – Adam May 21 '12 at 21:16
  • Buy Intel's card but problem still persist. I'm trying with 3.3.7 (latest stable) kernel now. – Andrej May 22 '12 at 6:15
  • I have tried on Debian Squeeze and WoL (S3, S4, and S5) works out-of-the-box. So the main issue is in kernel, I have no other idea. – Andrej Jun 7 '12 at 7:59

The LED doesn't necessarily have to be lit for the NIC to be listening to WOL, this is a common misconception. It depends on the NIC. I have a Windows PC where the LAN LED is out even though WOL works for it. Also, looking for attached devices in a router's i/f might not show truthfully if the NIC is listening for WOL or not. I have a PC which is not visible in the router's i/f when in sleep but WOL works. So all in all I don't think there's any good way to check if NIC is listening or completely shut down.

I posted my problem & investigation here, it could be the same problem: Wake-on-LAN worked 3 times then no more

My main suspicion righ now is that this problem occurs for RTL8111 users with Ubuntu 12.04.

There are also actually different version of RTL8111, who knows if it applies to all, and I don't know what the differences are between 8111C, 8168B, 8169 etc, they use the same driver on Linux. On Realtek's site, the same driver is used for the following NICs:

RTL8111B/RTL8168B/RTL8111/RTL8168 -- RTL8111C/RTL8111CP/RTL8111D(L) -- RTL8168C/RTL8111DP/RTL8111E -- RTL8168E/RTL8111F/RTL8411

and a different driver for the following NICs:

RTL8110SC(L) (RTL8110S/RTL8110SB(L)/RTL8169SB(L)/RTL8169S(L)/RTL8169)

Not allowed to post any more links.. :-/

If you want to buy a different NIC I suggest non-Realtek i e any Intel chip.

Update: I tested some more to understand what the problem is. My main theories for now ar: Ubuntu system shuts down NIC power in standby mode, and/or Realtek RTL8111 driver for 64-bit machines does not work. See link to my thread for details.

BTW I don't get this forum.. Am I posting an answer and the other ones are discussing although not allowed?! And I'm allowed to change the original post but can't add a comment!


I found a solution, it works on my system (RTL8111/8168B PCI Express Gigabit Ethernet + Ubuntu 12.04 AMD64). This bug report discribes the issue, and someone suggested that using the r8168 module instead of the r8169 module would do the trick. Also somewhere else I saw this can be done via dkms, but I'm in a rush this morning, so didn't get chance to look, this might help

wget http://r8168.googlecode.com/files/r8168-8.030.00.tar.bz2
tar xjf r8168-8.030.00.tar.bz2
cd r8168-8.030.00

Although I was doing this over ssh, it actually worked, the connection just locked for a while, but picked up again after the new module installed.


In addition to turning on support for wake-on-lan in the BIOS, I had to make another BIOS change.

In the BIOS, under "Power Management, I set "Deep Sleep Control" to disabled.

That allowed the NIC to stay on and show a link light even when the PC was off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.