1

I am trying to install volta.sh package library from which I wish to install Node.js and npm in Ubuntu 20.04 LTS. I tried:

curl https://get.volta.sh | bash

and got the error:

curl: (6) Could not resolve host: get.volta.sh

I edited the .bashrc and added the code:

export VOLTA_HOME="$HOME/.volta"
export PATH="$VOLTA_HOME/bin:$PATH"

I then closed and reopened the Ubuntu terminal, and tried again, getting the same error. Have also tried

sudo apt install nodejs

Which does not work. I am trying to work out what is wrong. Even to update

sudo apt update

results in errors:

Err:1 http://security.ubuntu.com/ubuntu focal-security InRelease
Temporary failure resolving 'security.ubuntu.com'

I have Ubuntu 20.04 LTS installed.

2
  • 1
    This sounds like a more general network problem - can you dig get.volta.sh or ping -c4 security.ubuntu.com or do you get similar resolver errors? Can you ping hosts by ip ex. ping -c4 8.8.8.8? Jun 26, 2021 at 15:26
  • Thanks for getting back to me. I thought it would be related somehow to network connection because of the failure to respond kind of messages. Though not sure how to resolve. These are the responses I get to the commands: dig get.volta.sh net.c:536: probing sendmsg() with IP_TOS=b8 failed: Network is unreachable ; <<>> DiG 9.16.1-Ubuntu <<>> get.volta.sh ;; global options: +cmd ;; connection timed out; no servers could be reached ping -c4 security.ubuntu.com ping: security.ubuntu.com: Temporary failure in name resolution ping -c4 8.8.8.8 ping: connect: Network is unreachable
    – Saira
    Jun 26, 2021 at 16:25

0

You must log in to answer this question.

Browse other questions tagged .