0

I have Asus Zenbook with AMD radeon graphics. After installing Ubuntu 18.04 LTs my laptop keyboard was working fine, but after updating and rebooting the laptop, the keyboard stopped working, not even in lock screen. USB keyboard still works. Touchpad also works.

I followed other similar questions on this topic and followed the following procedure:

sudo apt-get install xserver-xorg-input-all

after running this code in terminal, and rebooting the laptop, keyboard issue was solved. I did multiple reboots later and keyboard was still working. However, when I shutdown/poweroff the laptop, keyboard does not work when powered on again. So the problem is I have to run the above code everytime I switch on after shutdown.

Is there any way to solve the problem so that laptop keyboard works irrespective of shut down or reboot?

7
  • Try sudo dpkg-reconfigure keyboard.
    – paladin
    Jun 23 at 12:16
  • dpkg-query: package 'keyboard' is not installed and no information is available Use dpkg --info (= dpkg-deb --info) to examine archive files, and dpkg --contents (= dpkg-deb --contents) to list their contents. /usr/sbin/dpkg-reconfigure: keyboard is not installed Jun 24 at 7:08
  • This is what I am getting. Jun 24 at 7:08
  • Sorry I meant, sudo dpkg-reconfigure keyboard-configuration.
    – paladin
    Jun 24 at 7:13
  • I tried it. However after powering off and then powering on and booting to ubuntu makes the keyboard disabled. so the problem remains. Jun 25 at 20:46
0

I found a way to deal with the problem by running the command automatically on startup. Thus when I power on the laptop, the command is already executed. But the keyboard will not work until I reboot the laptop after executing the command. I use my touchpad to reboot the laptop from login screen. After reboot keyboard works fine.

So, every power on is followed by a manual reboot.

To run the command on start up, create a file /etc/rc.local using

sudo gedit /etc/rc.local

Then, paste the following in the file:

#!/bin/sh -e
apt install xserver-xorg-input-all
exit 0

save and close the file. Then make it executable:

sudo chmod +x /etc/rc.local

Next time after reboot, this command will be automatically executed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.