3

I’m turning GNOME animations off via the following command in the terminal:

gsettings set "org.gnome.desktop.interface" "enable-animations" "false"

This works the very first time. After that, after every fresh boot, the effect is gone. I have to repeat changing the setting. And that’s not even enough:

Just repeating the same command is not sufficient. I first have to invert the setting, then put in the setting that I actually want again:

gsettings set "org.gnome.desktop.interface" "enable-animations" "true"
gsettings set "org.gnome.desktop.interface" "enable-animations" "false"

The above is what I need after every boot. Why is that?

How I see the results? In the “gedit” text editor, smooth scrolling depends on animations being enabled.

Edit 1: Where can I see the (lack of) effect from this option after a reboot? In gedit (long text document) and Nautilus (longer list of folders and files in default view), smooth scrolling is disabled immediately after setting the option, but is enabled again after a reboot. On the contrary, in the “Applications” list opened from the dock, the open/close animation for the list remains disabled after a reboot, and smooth scrolling in the list remains disabled as well.

18
  • 1) The setting should be remembered. Maybe a permissions problem in your user account? To debug, temporarily create a fresh account and check whether the issue also occurs there. 2) Smooth scrolling should not depend on the setting for animations. It may be useful to include some info on your hardware and graphics card.
    – vanadium
    Jun 23 at 10:24
  • Thanks, @vanadium! Regarding (1): The first time I had executed gsettings on the machine (earlier), I had unintentionally used sudo, which caused problems because of the DBUS_SESSION_BUS_ADDRESS env variable and I think the error message was “failed to commit changes to dconf”. I guessed that could have caused permission problems, but I can’t find any problems in my home folder. Apart from that, the temporary second account, which you suggested, has the same problem as my first account: Applying the setting works immediately, but after a reboot, the effect is gone.
    – caw
    Jun 25 at 3:45
  • Regarding (2): Are you sure it shouldn’t? I found it in askubuntu.com/questions/903160/… and gitlab.gnome.org/GNOME/gedit/-/issues/42 and apparently it had that effect for years. The first link (question) is from 4 years ago. But I have just found another question here (where you also responded) and one answer describes exactly my problem (i.e. that setting being lost after reboot) – it’s 6.5 years old: askubuntu.com/a/562870 It references a bug report for Fedora that is 8 years old: bugzilla.redhat.com/show_bug.cgi?id=971677
    – caw
    Jun 25 at 3:51
  • That workaround for Fedora from 6.5 to 8 years ago didn’t work on my Ubuntu 20.04. I have an AMD graphics card, use X11 and Gnome 3.36.8, and have fractional scaling enabled.
    – caw
    Jun 25 at 4:05
  • 1
    @cav Well you could add the two lines to your .bashrc on your account, but does not seem to be a clean solution. It is a work around until we figure out the solution.
    – jpbrain
    Jun 29 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.