1

I would like to permanently disable Intel Turbo Boost on my Ubuntu 18.04 due to my PC processor reaching around 70°C. I managed to turn it off by executing below command

echo "1" | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo

but after computer restart turbo boost was enabled again. Is there any way to disable it permanently?

2
  • An method would be to put this command into your startup scripts. (See crontab)
    – FedKad
    Jun 22, 2021 at 9:48
  • Typically, it can be disabled in the BIOS if persistence is desired. Jun 22, 2021 at 14:14

1 Answer 1

0

Create a file using nano ==> /etc/rc.local

sudo nano /etc/rc.local

Edit rc.local like below.

#!/bin/bash -e
echo "1" > /sys/devices/system/cpu/intel_pstate/no_turbo
exit 0

Save the file and exit using Ctrl+S then Ctrl+X After that

sudo chmod +x /etc/rc.local

check after reboot this will work 100%.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .