0

I have followed multiple threads on this subject without success, any help will be appreciated! I have tried removing the synaptics as suggested here: Touchpad not working on Acer laptop I have also tried editing grub as recommended here: Ubuntu 20.04 Elantech touchpad not working As I said, no success. Here is what I see when I bring up the devices thrugh the command: cat /proc/bus/input/devices: I: Bus=0011 Vendor=0002 Product=000e Version=0000 N: Name="ETPS/2 Elantech Touchpad" P: Phys=isa0060/serio1/input0 S: Sysfs=/devices/platform/i8042/serio1/input/input5 U: Uniq= H: Handlers=mouse0 event4 B: PROP=5 B: EV=b B: KEY=e420 10000 0 0 0 0 B: ABS=661800011000003 I should mention that I tried installing Ubuntu 18.04 and 20.04. both have not had touchpad functionality from the begining, the only thing that I know is that the touchpad was working in Windows before I started the Ubuntu install. Does anyone know what else I should be looking at?

1 Answer 1

0

I had this problem and also undetected WiFi additionally to that (Acer Swift 1).

Both problems were solved by plugging in the external mouse, completing the install and then upgrading all packages to their latest versions (while still remaining with 20.04).

Another possible solution that I didn't try but that has good chances to succeed is downloading the latest installer (and not using an ancient one that I just happened to have laying around).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .