I want to install the Forticlient SSL VPN Client on Ubuntu 12.04.

I've downloaded the latest version from the Fortinent support site but when I try to run the installer (vía command line or GUI) it simply does nothing.

I have tried to install both with and without sudo but nothing happens.

I remember some time ago that I successfully installed the same client in CentOS and the client worked fine.

Can anyone help me to install this?

  • Would you please provide the result of that command , e.g any error message ? try launch it in e.g gnome-terminal – daisy May 10 '12 at 1:44
  • Unfortunately when i run the command in terminal i don't get any error message. – Juan May 10 '12 at 2:36
  • answer given by cortex for ubuntu 14.04 worked!! Thanks cortex. – Akhil Mudgal Sep 5 '14 at 6:55
  • On my Ubuntu 14.04, after install forticlientsslvpn_linux_4.4.2287.tar.gz I had to edit helper/sysconfig.linux.sh. To compute the ppp0 address, I had to replace the existing line with: addr=ifconfig ppp0 |grep "inet"|awk ' {print $3 }' – estibordo Nov 11 '14 at 18:40

You probably have the Ubuntu 64 bit version (at least it was my case). If so, just install the following package:

sudo apt-get install libgtk2.0-0:i386 xterm
  • This does not work for me: E: Couldn't find package libgtk2.0-0:i386 – Niels Bom May 25 '12 at 9:23

For those who are using 64bit ubuntu 14.04 (after clean install you have to install these packages)

sudo apt-get install libgtk2.0-0:i386 libsm6:i386 libstdc++6:i386 xterm

I have had it to work. However it wants you to accept a License Agreement which it will try to open in xterm. So make sure that xterm has been installed:

sudo apt-get install xterm

install 32-bit libralies.

$ sudo apt-get install ia32-libs-gtk

if you can run tunnel but traffic is not going through the tunnel.

You can try this note on Facebook.


i get well on ubuntu 12.10(x64)

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Kevin Bowen Jun 2 '13 at 9:09

Executing sudo apt-get install libgtk2.0-0:i386 was still giving me errors when running 12.04.

After executing sudo apt-get install ia32-libs-gtk FortiSSL is now running smoothly without any errors.


I know this is a bit old question, but I was searching myself for the forti client and now they have a package that do not require the ia-32 libs. You can download it from here.

More info

  • I am getting the following error "Dependency is not satisfiable libpango-1.0-0 (>=1.14.0)". I am using Ubuntu 12.04 64 bit. Any idea how to fix this? – Joswin K J Jan 6 '16 at 9:09
  • Hi @JoswinKJ . Please create a question stating your problem, and give me the link here in a comment. Also please state from where you have downloaded the fortinet client. – Mihai Jan 6 '16 at 10:04

You could download the package (tar.gz format) from support.fortinet.com. Once you extract the files, open the folders forticlientsslvpn > 32bit or 64bit, run the executable file "forticlientsslvpn" to launch the GUI.


Welcome Juan! Install openvpn first and try.To install it,type sudo apt-get install network-manager-openvpn in a terminal and reboot your system.I think this should solve your issue.

  • 1
    I've installed it but appears that openvpn client does not be compatible with Fortinet SSL VPN. – Juan May 10 '12 at 2:38

only CLI works under Ubuntu 13.10 because packages like libgtk2 or ia32-libs are not available anymore.

  • Please see here and here – user224082 Nov 17 '13 at 11:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.