2

I am new to Ubuntu, but am running Desktop 20.04. I have installed KVM and configured bridged networking per the following two links based on my understanding that the legacy networking service has been replaced by NetworkManager and netplan: Creating an ubuntu kvm networked bridge interface , How to setup bridge networking with kvm on ubuntu.

I am able to bridge my windows guest and it starts and runs with complete local network and internet connectivity. But when I start another windows guest, it crashes the first. And vice versa. Both are configured to use the host-bridge with a static IP.

My /etc/netplan/01-network-manager-all.yaml file contains: enter image description here

And the ip addr output confirms the bridge is working correctly: enter image description here

And networkctl list output is: enter image description here

And brctl list output is: enter image description here

Any help or suggestions would be greatly appreciate. Thank you.

4
  • You haven't specified a renderer in your .yaml file. I have seen other comments that it matters. Your IPs and MACs are different for each windows guest, correct? – Doug Smythies Jun 18 at 15:13
  • Yes, the IPs and MACs are unique for each guest. And I addded 'renderer: networkd' to the file, and restarted the systemd-networkd service. But the problem still persists. – matt01 Jun 20 at 15:00
  • Everything looks O.K. to me. As a test, I am running 3 VMs under 20.04, with bridged networking right now. I had a very very difficult time getting this working in early May. My problem turned out to be that my processor was too new for 20.04, and I had to enable HWE so as to have a newer kernel. The only significant difference I see between us, is that I have STP turned off. – Doug Smythies Jun 20 at 16:14
  • That is interesting. I had a "forced upgrade" as well as I damaged the old processor when upgrading the case & motherboard. I'm now running a Ryzen 7 5800x, which was released recently. So I wonder if there is an incompatibility with Ubuntu 20.04 desktop. Anyway, thank you for taking the time to look at the issue, @DougSmythies . – matt01 Jun 21 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.