1

I am pretty new here (and to Linux) so bear with me. I am recently transitioning from Windows 10 to Ubuntu 20.04 LTS. In doing so there has been some ups and downs. Currently, my biggest issue is getting my multiple monitor setup working (2 external as well as laptop screen, so 3 totoal). So I have a MSI GS73VR 6RF Stealth Pro laptop that has an Nvidia GTX 1060. I have a HDMI port as well as a mini display port. Initially, after some tinkering I was able to get all three displays working on the recommended nvidia-driver-460. But a reboot or suspension would disable at least one of the displays and I could never get it back. I then tried an updated one from the Software and Updates app: nvidia-driver-465 but I had the same thing happen.

I then tried rolling back to the nvidia-driver-390 but same issue. My kernel version is 5.8.0-55-generic. I then tried installing the driver manually (in recovery mode) the one on Nvidias site, that is NVIDIA-Linux-x86_64-460.84.run. After doing this I'd just get stuck at bootup on the MSI screen (with ubuntu logo below it). I had to enter recovery mode to get rid of everything Nvidia. Looking at the Software and Updates app it tells me I currently have the xserver-xorg-nouvea (open source) driver installed. That worked for a minute but same issue occured. I currently only have the display on my mini display port working. Everytime I go into display settings to turn on my other monitor the settings won't stick. Even when I had the Nvidia driver I tried using the Nvidia software to turn this on and it wouldn't stick.

I know the HW is fine since I used it for years with my Windows 10 Pro OS with no issues. Any help is appreciated. I'm sure I can add some config information here given some commands but again, pretty new so I will edit the post given your recommendations. Thank you for all your help!

Edit 1: reinstalled the recommended nvidia-driver-460 after doing so now I can see both my external monitors but my laptop monitor is not working now. heres an output from my xrandr if it helps...

    Screen 0: minimum 8 x 8, current 4920 x 2160, maximum 32767 x 32767
HDMI-0 connected primary 3840x2160+1080+0 (normal left inverted right x axis y axis) 621mm x 341mm
   3840x2160     60.00*+  59.94    50.00    30.00    29.97    25.00    23.98    23.98  
   2560x1600     59.97  
   2560x1440     59.95  
   1920x1080     60.00    59.94    50.00    60.00    50.04  
   1680x1050     59.95  
   1440x900      59.89  
   1440x576      50.00  
   1440x480      59.94  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
   640x350       70.07  
DP-0 connected 1080x1920+0+0 left (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00*+
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   640x480       75.00    59.94  
DP-1 disconnected (normal left inverted right x axis y axis)

So still an issue.Not sure how to get all three working still.

Edit 2:

Adding in inxi - G output:

Graphics:  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia v: 460.80 
           Display: x11 server: X.Org 1.20.9 driver: nvidia resolution: 3840x2160~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 460.80 

and the Xorg.0.log was to large to paste here so here is a pastebin link: https://pastebin.com/qLPfP6rB

Edit 3:

adding a bump, would love to not go back to Windows.

Edit 4: Again, adding a bump.

Edit 5: Again, adding another bump. Sorry for the edit clutter but just trying to get an answer on this.

Edit 6: Another another bump

Edit 7: Another bump

9
  • I believe I've answered that here – kanehekili Jun 18 at 13:32
  • I haven't fully tried your solution given that I had to install the Nvidia driver back in to use their software. When I did that I got back in the state where I'm stuck at msi/Ubuntu boot screen. I then hard powered down and hooked my monitors back up and it booted but it turned off and disabled my primary display (laptop). Like, I can't see it in Nvidia settings or the OS just my external ones show up and are usable. – wywypi Jun 20 at 11:17
  • any other thoughts or suggestions? – wywypi Jun 22 at 12:22
  • Another thought is, that the integrated Intel GPU (if not masked, i didn't find out) might "occupy" the eDP-x (llocal display). Then you might have to disable it in bios. It would help if you could paste the contents of inxi -G and the contents of "/var/log/Xorg.0.log" – kanehekili Jun 22 at 13:38
  • @kanehekili edited and updated per your requested info. Thanks! – wywypi Jun 22 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.