4

I bought a new laptop "Acer Aspire 5 A515-56-555H" with default OS - Windows 10 which running fine with all devices.

I manage to install Ubuntu 20.04 in separate disk partition, but WiFi and bluetooth do NOT work.

I notice Ubuntu 20.04 does not have Media Tek MT7921 driver for WIiFi and bluetooth.

How can I download & install the drivers?

Is there anyone who can help me?

3
  • askubuntu.com/questions/1333793/… and medium.com/@pjbgf/… indicates support with kernel 5.12+ (needs to be manually installed - there are always caveats when using non-standard kernels) Jun 18, 2021 at 7:33
  • Thanks for the idea. I'm not good on compiling kernel and manual install Linux 5.12 may encounter other issues :). Jun 18, 2021 at 13:54
  • My Asus Vivobook M7400Q had the MT7921 before I decided to replace it. On Ubuntu 20.04 / kernel 5.13 the WIFI adapter was either not found or it was found and would be very slow. Upgrading the kernel to 5.15.x and Ubuntu to 21.10 resolved some issues, but not all. The WIFI adapter would be detected in most cases, but not all. Bluetooth would not recognize my mouse anymore after sleep and wake up, forcing me to pair it again about 10 times per day. My advise: just buy an Intel AX200 for 20 eur with this laptop and install it. This adapter has zero WIFI or Bluetooth issues with Ubuntu 20.04
    – Julius
    Apr 6 at 9:16

5 Answers 5

3

You must upgrade the Linux kernel to 5.14, and the rest of Ubuntu to 21.04.

How to upgrade from Kernel 5.11 to 5.14 click here

How to upgrade from Ubuntu 20.04 to 21.04 click here

0
2

I was having the same issue on TUF A17. It has MT7961 chipset. I was able to fix it with updating to latest kernel release (5.15-rc6):

wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.15-rc6/amd64/linux-headers-5.15.0-051500rc6-generic_5.15.0-051500rc6.202110180730_amd64.deb
wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.15-rc6/amd64/linux-headers-5.15.0-051500rc6_5.15.0-051500rc6.202110180730_all.deb
wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.15-rc6/amd64/linux-image-unsigned-5.15.0-051500rc6-generic_5.15.0-051500rc6.202110180730_amd64.deb
wget https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.15-rc6/amd64/linux-modules-5.15.0-051500rc6-generic_5.15.0-051500rc6.202110180730_amd64.deb
sudo dpkg -i *.deb
sudo reboot now
1
  • I did this using ubuntu 21.04, and tried to install the latest mainline kernel (5.17), but got a dependency error related to libssl3. I ended up having to install 5.15.6 (the last version before libssl3 requirement) libssl3 is only available to 22.04+, as described here: unix.stackexchange.com/questions/685830/…
    – Tom Looby
    Mar 19 at 15:39
1

I also met similar problems with MediaTek wifi, MT79xx. I bought a ASUS laptop having that device. It didn't work in Ubuntu, 20.04. I tried various ways floating around the internet, installed several linux versions, did many things but failed at last. I spent a whole day.

I know that if you upgrade kernel module from 5.8 to 5.12 it should work as the kernel has the drivers supporting that device. But evem that didn't work for me. I think it has some bugs maybe.

I did learn that we can check whether any laptop is certified to work properly by Ubuntu: https://ubuntu.com/certified/laptops

3
  • so what you're saying is it just doesn't work yet... hopefully you can update this in the future when you find a way!
    – Zanna
    Aug 11, 2021 at 9:06
  • Yes. that's what I'm saying. I hope someone will fix those bugs in drive source, soon. Until that, many common wifi usb devices are another solution. Aug 11, 2021 at 15:45
  • This is the most correct answer as today's date. I installed latest kernel and WiFi not working. Period. Will shutdown Ubuntu and open after may be half a year. Thanks to MediTek. I'm using ASUS ROG Strix G15.
    – Pushpendra
    Oct 21, 2021 at 10:59
0

I got one of the newest ASUS TUF laptop and tried to install Ubuntu on it.

The touchpad did not work, Settings does not show Wi-Fi tab, and Bluetooth tab is not turning on...

At least Wi-Fi works after I upgraded Ubuntu to 21.04 and the kernel to 5.12. (Upgrading the kernel without upgrading Ubuntu did not work.)

The touchpad and bluetooth could work on a future kernel version...

3
  • check my answer GyuHyeon.
    – sonalkr132
    Oct 25, 2021 at 6:02
  • @sonalkr132 Shit, will it be finally working on 5.15? I am currently using 5.14... Oct 25, 2021 at 9:00
  • yes, I had the same issue as yours. wifi didn't work on 20.04, and updating to 21.04 with 5.14 fixed the wifi but not bluetooth. upating to 5.15-rc6 fixed bluetooth not turning on issue as well. I think this commit github.com/torvalds/linux/commit/… was needed.
    – sonalkr132
    Oct 25, 2021 at 13:00
0

My laptop is Lenovo Legion R7000P 2021, and its wireless network card is MediaTek MT7921.

I learned from this website that the minimum kernel version required for MT7921 is 5.12

So I updated the kernel to the newest version (5.15-rc7, the updated tutorial can refer to this), then WIFI can be used normally. Remember to reboot after updating the kernel

Just in case, I updated other software with command apt update and apt upgrade, and make sure that linux-firmware has been installed

Not the answer you're looking for? Browse other questions tagged or ask your own question.