I haven't added any VLC PPA's and I have no clue how to solve this problem.

If it's not possible to downgrade VLC, Running VLC in a portable mode is sufficient for me. I need the older version only for compatibility with a particular Android app.

System specs:

AMD PhenomX4,
GeForce6100PM-M2 V2.0

If my description of the problem is incomplete, Please point me to what information do you need.


You don't have to downgrade. You can run a portable version of VLC. Follow these steps:

  • Download portable version of VLC
  • Copy/move vlc to your home directory.
  • Right click on it and select properties.

  • In properties dialog box select "Permissions" tab and enable "Allow executing file as program" like shown below

    enter image description here

That's it. Now run it by right click and open.

  • I downloaded the "VLC 1.1.5" file, changed the permissions and when y tried to execute it (I tried both double click and right click and open), nothing happend. Then, I renamed it to "VLC1_1_5" for simple execute it on terminal. When I run $ ./VLC1_1_5 I get the following error message: ./VLC1_1_5: error while loading shared libraries: libfuse.so.2: wrong ELF class: ELFCLASS64 – tutucavoraz May 11 '12 at 0:42
  • @tutucavoraz You don't have to change the permissions, Just make it executable like shown in the screenshot. I just tried it and it's working fine for me. – Basharat Sialvi May 11 '12 at 0:49
  • That portable app is for a 32 bit install only, that's why you get the error. Also no need to be root to set as executable when stored/run from Home directory – doug May 11 '12 at 2:14
  • Solved! <pre> $ sudo apt-get install ia32-libs ia32-libs-gtk libc6-i386<br/> $ cd /tmp<br/> $ wget http://archive.ubuntu.com/ubuntu/pool/main/f/fuse/libfuse2_2.8.1-1.1ubuntu2_i386.deb<br/> $ dpkg --extract libfuse2_2.8.1-1.1ubuntu2_i386.deb libfuse<br/> $ sudo chown root:root libfuse/lib/lib*<br/> $ sudo mv libfuse/lib/lib* /lib32/<br/> $ rm -r libfuse<br/> </pre> Now a can run portable VLC (thanks @basharat-sial) in my 64-bits system considering 32-bits libraries (thanks @doug fot point that). – tutucavoraz May 26 '12 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.