1

I've just purchased a brand new computer and tried to install Ubuntu 20.04, but it only boots in safe graphics mode, and after installation, I get a black screen. When I go for 21.04, everything works fine, but I'd prefer the LTS version for obvious reasons.

Hardware details: Processor: Intel Core i5 10400 with onboard graphics, motherboard: Gigabyte Z590 GAMING X

Am I doing something wrong or is that hardware not supported by 20.04?

(I'm a hardware and linux noob)

5
  • What video, Intel's or add in video card? You may need newer kernel. See: unix.stackexchange.com/questions/642535/… Often very new hardware needs newest distribution to have latest kernel drivers. And some may be so new, you have to download the most recent kernel, not yet in standard distributions. When I built my system in 2016, I had to download the development version of 16.04 several months before it was released. I reinstalled after release, but it worked well. If willing to test/experiment you can try 21.10, also. – oldfred Jun 17 at 15:00
  • Video card? I'm not sure what you mean. That machine doesn't need high end graphics, it's for building Android apps, hence Ubuntu (and onboard graphics instead of graphics card). I'm not against using 21.04 per sé, I'm only concerned that I might run into issues when using a non LTS version for Android builds. – denverCoder9 Jun 17 at 15:16
  • Link is on the issue with Intel's graphics and needing different kernel. Intel usually is good about having drivers included well before hardware released, so included in Linux distributions. Not sure what issue is, if developers did not include some driver or compiled kernel without some setting? – oldfred Jun 17 at 15:22
  • Please post uname -r, I don't believe that your gaming comp has no external graphics card. Please install sudo apt install hwinfo and post the output of hwinfo --gfxcard – abu_bua Jun 17 at 16:55
  • It's not a gaming comp and there's no external graphics card. Confirmed by the commands you suggested, also confirmed by my eyes as I've opened up the thing to see what's inside :-) – denverCoder9 Jun 17 at 20:09
1

Intel Core i5 10400 was released in May 2020, after Ubuntu 20.04.

Your 20.04 kernel is too old for your hardware. Try a newer kernel.

  • You can test a newer kernel using a LiveUSB Installer's "Try Ubuntu" environment. This won't affect your current system, and is an easy way to check function before committing.

  • Alternately, you can upgrade your old LTS kernel using the HWE stack. This will affect your current system, and is difficult to undo if you're not an expert.

  • Or you can simply install a newer release of Ubuntu. Some complex non-Ubuntu software (like development environments) is packaged LTS releases only, and won;t work with other releases, so check your sources before committing to this path.

3
  • Thanks, that was very helpful. I'll try option 2 and see if it worked. – denverCoder9 Jun 17 at 20:19
  • Ok so I did a lot of research and I don't see how I can solve this at the moment. When I install 20.04, I can only install in safe graphics mode, and only boot in recovery mode. That means I also have no internet connection, and I have no idea how to upgrade the kernel without it. I have no problem with experimenting and possibly breaking things, but I think this is beyond my capabilities. – denverCoder9 Jun 18 at 8:30
  • Made some progress so I'm leaving this here for other clueless people: I downloaded Kernel 5.11.20 (loosely following method #1 from this guide: linuxhint.com/update_ubuntu_kernel_20_04) to a stick, and installed it in my 20.04 version. Now at least I have internet, but still no idea how to get intel graphics to work. – denverCoder9 Jun 18 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.