1

I've been breaking my head on this one for almost two weeks now and I really don't know how to solve this, I've followed dozens of askubuntu questions, bot none seems to help solve my problem.

Since two weeks my Ubuntu 20.04 LTS won't boot to login anymore after it autoinstalled some updates. It is most likely driver related, because booting to an older kernel with the default graphics driver works. I currently think the nvidia driver is causing some problems (nvidia-driver-460). It freezes after GRUB finishes booting (or how is this called?), but never reaches the Ubuntu loading screen nor the subsequential login screen: the screen is all black (white underscore in upper-right corner) and I cannot enter any TTY with the Ctrl+Alt+F1 commands. I can only force shutdown by holding the powerbutton to escape the frozen screen.

My hardware is:

  • AMD Ryzen 7 3700X
  • MSI GeForce RTX 2070 Super Gaming X Trio
  • MSI B450 Tomahawk MAX

I use Ubuntu in a dual-boot setting together with Windows 10, where each OS is installed on a seperate SSD. When the problems started I had a 5.4.0 linux kernel, but due to a reinstallation from Flash Drive I now have 5.8.0-55 kernel, though the problem still exists.

I tried using all types of nomodeset, nouveau.modeset=0, nouveau.nomodeset=0 etc. instead of quit splash in the linux line in the commands after pressing E at the GRUB menu (line: linux /boot... ...ro quiet splash $vt_handoff) without any results. I even tried reinstalling Ubuntu from a flash drive, but still the same problem occurs after installation.

The strange thing is when I click 'Try Ubuntu' when booting from the Flash Drive everything seems to work very properly, even having great graphics...

Booting Ubuntu from the SSD it's installed on again (so not from Flash Drive) in Recovery mode at least reaches the Recovery Menu, from here I can enter the root shell prompt.

Entering lshw -c video in the root prompt prints configuration: driver=nvidia latency=0. Subsequently entering nvidia-smi results in the root prompt freezing and once even stopped the shell abrubtly following a Kernel panic (?) stating it is not syncing:

...
Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b
efi: EFI Runtime Services are disabled!
Kernel Offset: 0x33e00000 from 0xfffffffff810000000 (relocation range: 0xfffffffffff8000000-0xfffffffbfffffff)
--- [ end Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b ] ---

I tried reinstalling older nvidia drivers; from the root shell prompt I managed to uninstall all nvidia related stuff:

sudo nvidia-installer --uninstall
apt purge nvidia*
reboot

and after this everything works just fine, however the system now uses the default graphics driver. Thereafter reinstalling older nvidia drivers (I tried 450 & 440) via the commands below results in the same boot freeze problem again

sudo apt update
sudo apt search nvidia*
sudo apt install nvidia-driver-440
sudo reboot 

What drivers do I have to use so I can use my GPU again?

1
  • workaround: I looked at the Flash Drive USB and saw that it used the nouveau drivers, I removed them from the blacklist config files in /etc/ and reinstalled them again. Everything seems to work fine now, though I am not using the drivers provided by Nvidia – Stefan Verweij Jun 21 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.